CVE-2020-13329 Cross-site scripting in GitLab

Medium 6.5 Published Updated

Attackers can inject malicious scripts into GitLab blob views, potentially stealing user sessions or executing code in victim browsers.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2020-13329?

CVE-2020-13329 is a medium-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 29 Sep 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

An issue has been discovered in GitLab affecting versions from 12.6.2 prior to 12.10.13. GitLab was vulnerable to a stored XSS by in the blob view feature.

Weakness: CWE-79

Which versions are affected by CVE-2020-13329?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 12.6.212.10.13

Products include Gitlab Gitlab.

How do I fix CVE-2020-13329?

Upgrade gitlab to 12.10.13 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2020-13329 being exploited?

There is no known exploitation of CVE-2020-13329 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2020-13329, GHSA-mx9j-jf6w-f9h8, UBUNTU-CVE-2020-13329.

Is CVE-2020-13329 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free