CVE-2020-13336 Cross-site scripting in GitLab
Attackers can inject malicious scripts into GitLab's error tracking feature, potentially stealing user sessions or data.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2020-13336?
CVE-2020-13336 is a medium-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 30 Sep 2020. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Official description
An issue has been discovered in GitLab affecting versions from 11.8 before 12.10.13. GitLab was vulnerable to a stored XSS by in the error tracking feature.
Weakness: CWE-79
Which versions are affected by CVE-2020-13336?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 11.8.0 | 12.10.13 |
Products include Gitlab Gitlab.
How do I fix CVE-2020-13336?
Upgrade gitlab to 12.10.13 or later.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2020-13336 being exploited?
There is no known exploitation of CVE-2020-13336 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2020-13336, GHSA-jpgp-p76h-hmp8, UBUNTU-CVE-2020-13336.