CVE-2020-13338 Cross-site scripting in GitLab

Medium 5.4 Published Updated

Attackers can inject malicious scripts via reference editing in GitLab, potentially leading to session hijacking or code execution.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2020-13338?

CVE-2020-13338 is a medium-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 2 Oct 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

An issue has been discovered in GitLab affecting versions prior to 12.10.13, 13.0.8, 13.1.2. A stored cross-site scripting vulnerability was discovered when editing references.

Weakness: CWE-79

Which versions are affected by CVE-2020-13338?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 8.10.012.10.13, 13.0.8, 13.1.2

Products include Gitlab Gitlab.

How do I fix CVE-2020-13338?

Upgrade gitlab to a fixed version for your release line: 12.10.13, 13.0.8 or 13.1.2.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2020-13338 being exploited?

There is no known exploitation of CVE-2020-13338 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2020-13338, GHSA-2qx5-mv7p-q62v, UBUNTU-CVE-2020-13338.

Is CVE-2020-13338 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free