CVE-2020-13340 Cross-site scripting in GitLab

High 8.7 Published Updated

Stored XSS in GitLab CI Job Logs allows attackers to execute malicious scripts in victim browsers, potentially leading to account takeover.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2020-13340?

CVE-2020-13340 is a high-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 8 Oct 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

An issue has been discovered in GitLab affecting all versions prior to 13.2.10, 13.3.7 and 13.4.2: Stored XSS in CI Job Log

Weakness: CWE-79

Which versions are affected by CVE-2020-13340?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 12.4.013.2.10, 13.3.7, 13.4.2

Products include Gitlab Gitlab.

How do I fix CVE-2020-13340?

Upgrade gitlab to a fixed version for your release line: 13.2.10, 13.3.7 or 13.4.2.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2020-13340 being exploited?

There is no known exploitation of CVE-2020-13340 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2020-13340, GHSA-2hgm-r8rh-g5xg, UBUNTU-CVE-2020-13340.

Is CVE-2020-13340 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free