CVE-2020-13342 Denial of service in GitLab

Low 2.7 Published Updated

Attackers can exhaust resources by repeatedly triggering confirmation email resends due to missing rate limits, impacting GitLab availability.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2020-13342?

CVE-2020-13342 is a low-severity denial of service vulnerability in Gitlab Gitlab, published on 7 Oct 2020. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

An issue has been discovered in GitLab affecting versions prior to 13.2.10, 13.3.7 and 13.4.2: Lack of Rate Limiting at Re-Sending Confirmation Email

Weakness: CWE-770

Which versions are affected by CVE-2020-13342?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 10.1.013.2.10, 13.3.7, 13.4.2

Products include Gitlab Gitlab.

How do I fix CVE-2020-13342?

Upgrade gitlab to a fixed version for your release line: 13.2.10, 13.3.7 or 13.4.2.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2020-13342 being exploited?

There is no known exploitation of CVE-2020-13342 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2020-13342, GHSA-pcf2-p33r-6879, UBUNTU-CVE-2020-13342.

Is CVE-2020-13342 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free