CVE-2020-13353 Gitaly Insufficient Session Expiration vulnerability
Attackers can access persisted one-time git credentials when importing repositories via URL in Gitaly, leading to potential credential exposure.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-13353?
CVE-2020-13353 is a low-severity vulnerability in GitLab Gitaly, published on 17 Nov 2020. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
When importing repos via URL, one time use git credentials were persisted beyond the expected time window in Gitaly 1.79.0 or above.
Weakness: CWE-613
Which versions are affected by CVE-2020-13353?
6 open source packages ship an affected version, including gitaly. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitaly RubyGems | From 1.79.0 | 13.3.9 |
gitaly RubyGems | From 1.79.0 | 13.3.9 |
gitaly RubyGems | From 13.4 | 13.4.5 |
gitaly RubyGems | From 13.4 | 13.4.5 |
gitaly RubyGems | From 13.5 | 13.5.2 |
gitaly RubyGems | From 13.5 | 13.5.2 |
Products include Gitlab Gitaly.
How do I fix CVE-2020-13353?
Upgrade gitaly to a fixed version for your release line: 13.3.9, 13.4.5 or 13.5.2.
Is CVE-2020-13353 being exploited?
There is no known exploitation of CVE-2020-13353 in the wild and no public exploit code.
Sources
Also known as DEBIAN-CVE-2020-13353, GHSA-mmmm-chjf-jmvw.