# CVE-2020-13353: Gitaly Insufficient Session Expiration vulnerability

> Attackers can access persisted one-time git credentials when importing repositories via URL in Gitaly, leading to potential credential exposure.

- **Severity:** Low 2.5 (`CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Nov 2020
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2020-13353, GHSA-mmmm-chjf-jmvw

## What is CVE-2020-13353?

CVE-2020-13353 is a low-severity vulnerability in GitLab Gitaly, published on 17 Nov 2020. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

When importing repos via URL, one time use git credentials were persisted beyond the expected time window in Gitaly 1.79.0 or above.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2020-13353?

6 open source packages ship an affected version, including gitaly. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitaly` | RubyGems | From 1.79.0 | 13.3.9 |
| `gitaly` | RubyGems | From 1.79.0 | 13.3.9 |
| `gitaly` | RubyGems | From 13.4 | 13.4.5 |
| `gitaly` | RubyGems | From 13.4 | 13.4.5 |
| `gitaly` | RubyGems | From 13.5 | 13.5.2 |
| `gitaly` | RubyGems | From 13.5 | 13.5.2 |

Products: Gitlab Gitaly.

## How do I fix CVE-2020-13353?

Upgrade gitaly to a fixed version for your release line: 13.3.9, 13.4.5 or 13.5.2.

## Is CVE-2020-13353 being exploited?

There is no known exploitation of CVE-2020-13353 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-13353 and fix it if it is affected.

What it is: CVE-2020-13353 is a low-severity vulnerability in GitLab Gitaly, published on 17 Nov 2020. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-13353 in the wild and no public exploit code.

Affected packages and fixed versions:
- gitaly (RubyGems): affected from 1.79.0; fixed in 13.3.9
- gitaly (RubyGems): affected from 1.79.0; fixed in 13.3.9
- gitaly (RubyGems): affected from 13.4; fixed in 13.4.5
- gitaly (RubyGems): affected from 13.4; fixed in 13.4.5
- gitaly (RubyGems): affected from 13.5; fixed in 13.5.2
- gitaly (RubyGems): affected from 13.5; fixed in 13.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-13353/ (Markdown: https://insights.sbomify.com/CVE-2020-13353/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-13353
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-13353
- OSV: https://osv.dev/vulnerability/CVE-2020-13353

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-13353/
Summaries are generated and may contain mistakes; the official description above is the record.
