{"answers":{"affected":"3 open source packages ship an affected version, including jw-util and jw.util. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-13388 in the wild and no public exploit code.","fix":"Upgrade jw-util to 2.3 or later.","what":"CVE-2020-13388 is a critical code injection vulnerability in n/a, published on 22 May 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-13388 and fix it if it is affected.\n\nWhat it is: CVE-2020-13388 is a critical code injection vulnerability in n/a, published on 22 May 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-13388 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- jw-util (PyPI): affected all versions; fixed in 2.3\n- jw-util (PyPI): affected all versions; fixed in 2.3\n- jw.util (PyPI): affected all versions; fixed in 2.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-13388/ (Markdown: https://insights.sbomify.com/CVE-2020-13388/index.md)","id":"CVE-2020-13388","markdown":"https://insights.sbomify.com/CVE-2020-13388/index.md","name":"CVE-2020-13388","record":{"aliases":["GHSA-h72c-w3q3-55qq","PYSEC-2020-341"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Python jw.util package","requires_auth":"none","summary":"Attackers can execute arbitrary Python code via unsafe YAML parsing in the jw.util package, leading to OS command execution.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"jw.util","vendor":"python"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"An exploitable vulnerability exists in the configuration-loading functionality of the jw.util package before 2.3 for Python. When loading a configuration with FromString or FromStream with YAML, one can execute arbitrary Python code, resulting in OS command execution, because safe_load is not used.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"OS Command Injection in jw.util","id":"CVE-2020-13388","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"code_injection","year":"2020"},"n_packages":3,"n_references":3,"next":{"headline":"Memory corruption in n/a","id":"CVE-2020-13389"},"packages":[{"ecosystem":"PyPI","fixed":["2.3"],"introduced":["0"],"last_affected":[],"package":"jw-util","purl":"pkg:pypi/jw-util","source":"GHSA-h72c-w3q3-55qq"},{"ecosystem":"PyPI","fixed":["2.3"],"introduced":["0"],"last_affected":[],"package":"jw-util","purl":"pkg:pypi/jw-util","source":"PYSEC-2020-341"},{"ecosystem":"PyPI","fixed":["2.3"],"introduced":["0"],"last_affected":[],"package":"jw.util","purl":null,"source":"GHSA-h72c-w3q3-55qq"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2020-13387"},"products":["n/a"],"published":"2020-05-22","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Attackers can execute arbitrary Python code via unsafe YAML parsing in the jw.util package, leading to OS command execution.","url":"https://insights.sbomify.com/CVE-2020-13388/"}