# CVE-2020-13388: OS Command Injection in jw.util

> Attackers can execute arbitrary Python code via unsafe YAML parsing in the jw.util package, leading to OS command execution.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 May 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-h72c-w3q3-55qq, PYSEC-2020-341

## What is CVE-2020-13388?

CVE-2020-13388 is a critical code injection vulnerability in n/a, published on 22 May 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An exploitable vulnerability exists in the configuration-loading functionality of the jw.util package before 2.3 for Python. When loading a configuration with FromString or FromStream with YAML, one can execute arbitrary Python code, resulting in OS command execution, because safe_load is not used.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2020-13388?

3 open source packages ship an affected version, including jw-util and jw.util. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jw-util` | PyPI | All versions | 2.3 |
| `jw-util` | PyPI | All versions | 2.3 |
| `jw.util` | PyPI | All versions | 2.3 |

Products: Python Jw.util.

## How do I fix CVE-2020-13388?

Upgrade jw-util to 2.3 or later.

## Is CVE-2020-13388 being exploited?

There is no known exploitation of CVE-2020-13388 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-13388 and fix it if it is affected.

What it is: CVE-2020-13388 is a critical code injection vulnerability in n/a, published on 22 May 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-13388 in the wild and no public exploit code.

Affected packages and fixed versions:
- jw-util (PyPI): affected all versions; fixed in 2.3
- jw-util (PyPI): affected all versions; fixed in 2.3
- jw.util (PyPI): affected all versions; fixed in 2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-13388/ (Markdown: https://insights.sbomify.com/CVE-2020-13388/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-13388
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-13388
- OSV: https://osv.dev/vulnerability/CVE-2020-13388

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-13388/
Summaries are generated and may contain mistakes; the official description above is the record.
