# CVE-2020-13401: Improper Input Validation in Docker Engine

> An attacker in a container with CAP_NET_RAW can spoof IPv6 hosts, leak information, or cause denial of service via crafted router advertisements.

- **Severity:** Medium 6.0 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Jun 2020
- **Updated:** 4 Aug 2024
- **Also known as:** CLEANSTART-2026-LO92201, DEBIAN-CVE-2020-13401, DSA-4716-1, GHSA-qrrc-ww9x-r43g, MGASA-2020-0279, SUSE-SU-2020:1657-1, SUSE-SU-2020:1657-2, SUSE-SU-2020:1664-1, UBUNTU-CVE-2020-13401, openSUSE-SU-2020:0846-1

## What is CVE-2020-13401?

CVE-2020-13401 is a medium-severity vulnerability in Debian Debian Linux, published on 2 Jun 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An issue was discovered in Docker Engine before 19.03.11. An attacker in a container, with the CAP_NET_RAW capability, can craft IPv6 router advertisements, and consequently spoof external IPv6 hosts, obtain sensitive information, or cause a denial of service.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2020-13401?

2 open source packages ship an affected version, including github.com/docker/docker-ce. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/docker/docker-ce` | Go | All versions | 19.03.11 |
| `github.com/docker/docker-ce` | Go | All versions | 19.03.11 |
| `containerd` | SUSE:Linux Enterprise Module for Containers 12 | All versions | 1.2.13-16.29.1 |
| `docker` | SUSE:Linux Enterprise Module for Containers 12 | All versions | 19.03.11_ce-98.54.1 |
| `docker-runc` | SUSE:Linux Enterprise Module for Containers 12 | All versions | 1.0.0rc10+gitr3981_dc9208a3303f-1.46.1 |
| `golang-github-docker-libnetwork` | SUSE:Linux Enterprise Module for Containers 12 | All versions | 0.7.0.1+gitr2902_153d0769a118-31.1 |
| `containerd` | SUSE:Linux Enterprise Module for Containers 15 SP1 | All versions | 1.2.13-5.22.2 |
| `docker` | SUSE:Linux Enterprise Module for Containers 15 SP1 | All versions | 19.03.11_ce-6.34.2 |
| `docker-runc` | SUSE:Linux Enterprise Module for Containers 15 SP1 | All versions | 1.0.0rc10+gitr3981_dc9208a3303f-6.38.2 |
| `golang-github-docker-libnetwork` | SUSE:Linux Enterprise Module for Containers 15 SP1 | All versions | 0.7.0.1+gitr2902_153d0769a118-4.21.2 |
| `containerd` | SUSE:Linux Enterprise Module for Containers 15 SP2 | All versions | 1.2.13-5.22.2 |
| `docker` | SUSE:Linux Enterprise Module for Containers 15 SP2 | All versions | 19.03.11_ce-6.34.2 |
| `docker-runc` | SUSE:Linux Enterprise Module for Containers 15 SP2 | All versions | 1.0.0rc10+gitr3981_dc9208a3303f-6.38.2 |
| `golang-github-docker-libnetwork` | SUSE:Linux Enterprise Module for Containers 15 SP2 | All versions | 0.7.0.1+gitr2902_153d0769a118-4.21.2 |
| `containerd` | openSUSE:Leap 15.1 | All versions | 1.2.13-lp151.2.12.1 |
| `docker` | openSUSE:Leap 15.1 | All versions | 19.03.11_ce-lp151.2.18.1 |
| `docker-runc` | openSUSE:Leap 15.1 | All versions | 1.0.0rc10+gitr3981_dc9208a3303f-lp151.3.21.1 |
| `golang-github-docker-libnetwork` | openSUSE:Leap 15.1 | All versions | 0.7.0.1+gitr2902_153d0769a118-lp151.2.12.1 |

Products: Broadcom Sannav, Debian Debian Linux, Docker Engine, Fedoraproject Fedora.

## How do I fix CVE-2020-13401?

Upgrade github.com/docker/docker-ce to 19.03.11 or later.

## Is CVE-2020-13401 being exploited?

There is no known exploitation of CVE-2020-13401 in the wild and no public exploit code.

Public exploit code:

- Study on CVE-2020-13401 vulnerability of containers in dockers older than 19.03.11 (github_poc): https://github.com/arax-zaeimi/Docker-Container-CVE-2020-13401

## Other vulnerabilities in Debian Debian Linux

- [CVE-2022-2068](https://insights.sbomify.com/CVE-2022-2068/): The c_rehash script allows command injection (critical 9.8)
- [CVE-2022-28163](https://insights.sbomify.com/CVE-2022-28163/): SQL injection in Brocade SANNav (critical 9.8)
- [CVE-2020-15377](https://insights.sbomify.com/CVE-2020-15377/): Server-side request forgery in Brocade SANnav (critical 9.8)
- [CVE-2022-28165](https://insights.sbomify.com/CVE-2022-28165/): Missing authorization in Brocade SANNav (high 8.8)
- [CVE-2025-12772](https://insights.sbomify.com/CVE-2025-12772/): Plaintext Switch admin login password is seen in Brocade SANnav support save (high 8.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-13401 and fix it if it is affected.

What it is: CVE-2020-13401 is a medium-severity vulnerability in Debian Debian Linux, published on 2 Jun 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-13401 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/docker/docker-ce (Go): affected all versions; fixed in 19.03.11
- github.com/docker/docker-ce (Go): affected all versions; fixed in 19.03.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-13401/ (Markdown: https://insights.sbomify.com/CVE-2020-13401/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-13401
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-13401
- OSV: https://osv.dev/vulnerability/CVE-2020-13401

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-13401/
Summaries are generated and may contain mistakes; the official description above is the record.
