# CVE-2020-13410: Improper exception handling in Aedes

> An attacker can cause a denial of service in the Aedes MQTT broker by sending an invalid packet that triggers an unhandled exception during stream writing.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Aug 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-gh78-48h3-frjq

## What is CVE-2020-13410?

CVE-2020-13410 is a high-severity denial of service vulnerability in n/a, published on 26 Aug 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in MoscaJS Aedes 0.42.0. lib/write.js does not properly consider exceptions during the writing of an invalid packet to a stream.

Weakness: CWE-755 (Improper Handling of Exceptional Conditions)

## Which versions are affected by CVE-2020-13410?

2 open source packages ship an affected version, including aedes. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `aedes` | npm | All versions | 0.42.1 |
| `aedes` | npm | All versions | 0.42.1 |

Products: Aedes Project Aedes.

## How do I fix CVE-2020-13410?

Upgrade aedes to 0.42.1 or later.

## Is CVE-2020-13410 being exploited?

There is no known exploitation of CVE-2020-13410 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2018-3778](https://insights.sbomify.com/CVE-2018-3778/): Improper Authorization in aedes (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-13410 and fix it if it is affected.

What it is: CVE-2020-13410 is a high-severity denial of service vulnerability in n/a, published on 26 Aug 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-13410 in the wild and no public exploit code.

Affected packages and fixed versions:
- aedes (npm): affected all versions; fixed in 0.42.1
- aedes (npm): affected all versions; fixed in 0.42.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-13410/ (Markdown: https://insights.sbomify.com/CVE-2020-13410/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-13410
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-13410
- OSV: https://osv.dev/vulnerability/CVE-2020-13410

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-13410/
Summaries are generated and may contain mistakes; the official description above is the record.
