{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-13429 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2020-13429 is a medium-severity cross-site scripting vulnerability in n/a, published on 24 May 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-13429 and fix it if it is affected.\n\nWhat it is: CVE-2020-13429 is a medium-severity cross-site scripting vulnerability in n/a, published on 24 May 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-13429 in the wild and no public exploit code.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-13429/ (Markdown: https://insights.sbomify.com/CVE-2020-13429/index.md)","id":"CVE-2020-13429","markdown":"https://insights.sbomify.com/CVE-2020-13429/index.md","name":"CVE-2020-13429","record":{"aliases":["GHSA-2cxp-qfw2-vrc8","SUSE-SU-2021:3174-1","openSUSE-SU-2021:1308-1","openSUSE-SU-2021:3175-1","openSUSE-SU-2024:10819-1"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Grafana plugin","requires_auth":"low_privilege","summary":"Cross-site scripting vulnerability in the Grafana Pie Chart Panel plugin allows attackers to inject malicious scripts via the legend header option.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"piechart-panel","vendor":"grafana"}],"cvss":{"score":5.4,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"legend.ts in the piechart-panel (aka Pie Chart Panel) plugin before 1.5.0 for Grafana allows XSS via the Values Header (aka legend header) option.","ecosystems":["SUSE:Enterprise Storage 6","openSUSE:Leap 15.2","openSUSE:Leap 15.3","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site scripting in n/a","id":"CVE-2020-13429","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2020"},"n_packages":4,"n_references":2,"next":{"headline":"Grafana XSS via the OpenTSDB datasource","id":"CVE-2020-13430"},"packages":[{"ecosystem":"SUSE:Enterprise Storage 6","fixed":["1.6.1-3.3.1"],"introduced":["0"],"last_affected":[],"package":"grafana-piechart-panel","purl":"pkg:rpm/suse/grafana-piechart-panel\u0026distro=SUSE%20Enterprise%20Storage%206","source":"SUSE-SU-2021:3174-1"},{"ecosystem":"openSUSE:Leap 15.2","fixed":["1.6.1-lp152.2.6.1"],"introduced":["0"],"last_affected":[],"package":"grafana-piechart-panel","purl":"pkg:rpm/opensuse/grafana-piechart-panel\u0026distro=openSUSE%20Leap%2015.2","source":"openSUSE-SU-2021:1308-1"},{"ecosystem":"openSUSE:Leap 15.3","fixed":["1.6.1-3.6.1"],"introduced":["0"],"last_affected":[],"package":"grafana-piechart-panel","purl":"pkg:rpm/opensuse/grafana-piechart-panel\u0026distro=openSUSE%20Leap%2015.3","source":"openSUSE-SU-2021:3175-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.6.1-2.2"],"introduced":["0"],"last_affected":[],"package":"grafana-piechart-panel","purl":"pkg:rpm/opensuse/grafana-piechart-panel\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:10819-1"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2020-13428"},"products":["n/a"],"published":"2020-05-24","related":[{"cvss_score":6.1,"headline":"Cross-site scripting in n/a","id":"CVE-2015-9282","kev_date_added":null,"published":"2019-02-06"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Cross-site scripting vulnerability in the Grafana Pie Chart Panel plugin allows attackers to inject malicious scripts via the legend header option.","url":"https://insights.sbomify.com/CVE-2020-13429/"}