# CVE-2020-13458: Image Resizer Cross-Site Request Forgery (CSRF)

> Cross-site request forgery in the Image Resizer plugin allows attackers to force log clearing actions on behalf of authenticated users.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 May 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-5v5q-3m7m-97j7

## What is CVE-2020-13458?

CVE-2020-13458 is a high-severity vulnerability in n/a, published on 25 May 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

An issue was discovered in the Image Resizer plugin before 2.0.9 for Craft CMS. There are CSRF issues with the log-clear controller action.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2020-13458?

2 open source packages ship an affected version, including verbb/image-resizer. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `verbb/image-resizer` | Packagist | All versions | 2.0.9 |
| `verbb/image-resizer` | Packagist | All versions | 2.0.9 |

Products: Verbb Image Resizer.

## How do I fix CVE-2020-13458?

Upgrade verbb/image-resizer to 2.0.9 or later.

## Is CVE-2020-13458 being exploited?

There is no known exploitation of CVE-2020-13458 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2020-13459](https://insights.sbomify.com/CVE-2020-13459/): Image Resizer Cross-site Scripting (XSS) in the Bulk Resize action (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-13458 and fix it if it is affected.

What it is: CVE-2020-13458 is a high-severity vulnerability in n/a, published on 25 May 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-13458 in the wild and no public exploit code.

Affected packages and fixed versions:
- verbb/image-resizer (Packagist): affected all versions; fixed in 2.0.9
- verbb/image-resizer (Packagist): affected all versions; fixed in 2.0.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-13458/ (Markdown: https://insights.sbomify.com/CVE-2020-13458/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-13458
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-13458
- OSV: https://osv.dev/vulnerability/CVE-2020-13458

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-13458/
Summaries are generated and may contain mistakes; the official description above is the record.
