# CVE-2020-13661: Command injection in n/a

> Attackers can execute arbitrary programs via crafted hostnames when users select Open On Browser in Telerik Fiddler.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 5 Nov 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-gf4w-r33x-hg8c

## What is CVE-2020-13661?

CVE-2020-13661 is a high-severity command injection vulnerability in n/a, published on 5 Nov 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Telerik Fiddler through 5.0.20202.18177 allows attackers to execute arbitrary programs via a hostname with a trailing space character, followed by --utility-and-browser --utility-cmd-prefix= and the pathname of a locally installed program. The victim must interactively choose the Open On Browser option. Fixed in version 5.0.20204.

## Which versions are affected by CVE-2020-13661?

It affects 1 product.


Products: Telerik Fiddler.

## How do I fix CVE-2020-13661?

No fix has been published for CVE-2020-13661 yet. Limit exposure of the affected software until one is available.

## Is CVE-2020-13661 being exploited?

There is no known exploitation of CVE-2020-13661 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-13661 and fix it if it is affected.

What it is: CVE-2020-13661 is a high-severity command injection vulnerability in n/a, published on 5 Nov 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-13661 in the wild and no public exploit code.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-13661/ (Markdown: https://insights.sbomify.com/CVE-2020-13661/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-13661
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-13661
- OSV: https://osv.dev/vulnerability/CVE-2020-13661

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-13661/
Summaries are generated and may contain mistakes; the official description above is the record.
