CVE-2020-13664 Drupal Core Arbitrary PHP code execution vulnerability
An attacker can achieve remote code execution on Drupal Core by tricking an administrator into creating a specific directory, primarily affecting Windows servers.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2020-13664?
CVE-2020-13664 is a high-severity command injection vulnerability in Drupal Drupal, published on 5 May 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Arbitrary PHP code execution vulnerability in Drupal Core under certain circumstances. An attacker could trick an administrator into visiting a malicious site that could result in creating a carefully named directory on the file system. With this directory in place, an attacker could attempt to brute force a remote code execution vulnerability. Windows servers are most likely to be affected. This issue affects: Drupal Drupal Core 8.8.x versions prior to 8.8.8; 8.9.x versions prior to 8.9.1; 9.0.1 versions prior to 9.0.1.
Weakness: CWE-77
Which versions are affected by CVE-2020-13664?
14 open source packages ship an affected version, including drupal/core, drupal and drupal/drupal. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
drupal/core Packagist | From 8.0.0 | 8.8.8, 8.9.1, 9.0.1 |
drupal/core Packagist | From 8.8.0 | 8.8.8 |
drupal/core Packagist | From 8.8.0 | 8.8.8 |
drupal/core Packagist | From 8.9.0 | 8.9.1 |
drupal/core Packagist | From 8.9.0 | 8.9.1 |
drupal/core Packagist | From 9.0.0 | 9.0.1 |
8 more packages
drupal/core Packagist | From 9.0.0 | 9.0.1 |
drupal Bitnami | From 8.8.0 | 8.8.8, 8.9.1, 9.0.1 |
drupal/drupal Packagist | From 8.8.0 | 8.8.8 |
drupal/drupal Packagist | From 8.8.0 | 8.8.8 |
drupal/drupal Packagist | From 8.9.0 | 8.9.1 |
drupal/drupal Packagist | From 8.9.0 | 8.9.1 |
drupal/drupal Packagist | From 9.0.0 | 9.0.1 |
drupal/drupal Packagist | From 9.0.0 | 9.0.1 |
Products include Drupal Drupal.
How do I fix CVE-2020-13664?
Upgrade drupal/core to a fixed version for your release line: 8.8.8, 8.9.1 or 9.0.1.
Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.
Is CVE-2020-13664 being exploited?
There is no known exploitation of CVE-2020-13664 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Drupal Drupal
Sources
Also known as BIT-drupal-2020-13664, DRUPAL-CORE-2020-005, GHSA-x72f-ggjw-v5xh.