# CVE-2020-13664: Drupal Core Arbitrary PHP code execution vulnerability

> An attacker can achieve remote code execution on Drupal Core by tricking an administrator into creating a specific directory, primarily affecting Windows servers.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 5 May 2021
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-drupal-2020-13664, DRUPAL-CORE-2020-005, GHSA-x72f-ggjw-v5xh

## What is CVE-2020-13664?

CVE-2020-13664 is a high-severity command injection vulnerability in Drupal Drupal, published on 5 May 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Arbitrary PHP code execution vulnerability in Drupal Core under certain circumstances. An attacker could trick an administrator into visiting a malicious site that could result in creating a carefully named directory on the file system. With this directory in place, an attacker could attempt to brute force a remote code execution vulnerability. Windows servers are most likely to be affected. This issue affects: Drupal Drupal Core 8.8.x versions prior to 8.8.8; 8.9.x versions prior to 8.9.1; 9.0.1 versions prior to 9.0.1.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2020-13664?

14 open source packages ship an affected version, including drupal/core, drupal and drupal/drupal. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `drupal/core` | Packagist | From 8.0.0 | 8.8.8, 8.9.1, 9.0.1 |
| `drupal/core` | Packagist | From 8.8.0 | 8.8.8 |
| `drupal/core` | Packagist | From 8.8.0 | 8.8.8 |
| `drupal/core` | Packagist | From 8.9.0 | 8.9.1 |
| `drupal/core` | Packagist | From 8.9.0 | 8.9.1 |
| `drupal/core` | Packagist | From 9.0.0 | 9.0.1 |
| `drupal/core` | Packagist | From 9.0.0 | 9.0.1 |
| `drupal` | Bitnami | From 8.8.0 | 8.8.8, 8.9.1, 9.0.1 |
| `drupal/drupal` | Packagist | From 8.8.0 | 8.8.8 |
| `drupal/drupal` | Packagist | From 8.8.0 | 8.8.8 |
| `drupal/drupal` | Packagist | From 8.9.0 | 8.9.1 |
| `drupal/drupal` | Packagist | From 8.9.0 | 8.9.1 |
| `drupal/drupal` | Packagist | From 9.0.0 | 9.0.1 |
| `drupal/drupal` | Packagist | From 9.0.0 | 9.0.1 |

Products: Drupal Drupal.

## How do I fix CVE-2020-13664?

Upgrade drupal/core to a fixed version for your release line: 8.8.8, 8.9.1 or 9.0.1.

## Is CVE-2020-13664 being exploited?

There is no known exploitation of CVE-2020-13664 in the wild and no public exploit code.

Public exploit code:

- PoC for CVE-2020-13664 (github_poc): https://github.com/lorenzog/CVE-2020-13664

## Other vulnerabilities in Drupal Drupal

- [CVE-2026-9082](https://insights.sbomify.com/CVE-2026-9082/): Drupal Core SQL Injection (critical 9.8, exploited in the wild)
- [CVE-2020-13671](https://insights.sbomify.com/CVE-2020-13671/): Drupal core Un-restricted Upload of File (high 8.8, exploited in the wild)
- [CVE-2019-6340](https://insights.sbomify.com/CVE-2019-6340/): Drupal Core Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2009-3352](https://insights.sbomify.com/CVE-2009-3352/): Other in n/a (critical 10.0)
- [CVE-2024-55636](https://insights.sbomify.com/CVE-2024-55636/): Drupal core - Less critical - Gadget chain - SA-CORE-2024-006 (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-13664 and fix it if it is affected.

What it is: CVE-2020-13664 is a high-severity command injection vulnerability in Drupal Drupal, published on 5 May 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-13664 in the wild and no public exploit code.

Affected packages and fixed versions:
- drupal/core (Packagist): affected from 8.0.0; fixed in 8.8.8, 8.9.1, 9.0.1
- drupal/core (Packagist): affected from 8.8.0; fixed in 8.8.8
- drupal/core (Packagist): affected from 8.8.0; fixed in 8.8.8
- drupal/core (Packagist): affected from 8.9.0; fixed in 8.9.1
- drupal/core (Packagist): affected from 8.9.0; fixed in 8.9.1
- drupal/core (Packagist): affected from 9.0.0; fixed in 9.0.1
- drupal/core (Packagist): affected from 9.0.0; fixed in 9.0.1
- drupal (Bitnami): affected from 8.8.0; fixed in 8.8.8, 8.9.1, 9.0.1
- drupal/drupal (Packagist): affected from 8.8.0; fixed in 8.8.8
- drupal/drupal (Packagist): affected from 8.8.0; fixed in 8.8.8
- drupal/drupal (Packagist): affected from 8.9.0; fixed in 8.9.1
- drupal/drupal (Packagist): affected from 8.9.0; fixed in 8.9.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-13664/ (Markdown: https://insights.sbomify.com/CVE-2020-13664/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-13664
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-13664
- OSV: https://osv.dev/vulnerability/CVE-2020-13664

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-13664/
Summaries are generated and may contain mistakes; the official description above is the record.
