CVE-2020-13666 Drupal Core Cross-site scripting vulnerability
Attackers can execute arbitrary scripts in user browsers via the Drupal AJAX API's JSONP feature, potentially leading to session hijacking or data theft.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2020-13666?
CVE-2020-13666 is a medium-severity cross-site scripting vulnerability in Drupal Drupal, published on 5 May 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Cross-site scripting vulnerability in Drupal Core. Drupal AJAX API does not disable JSONP by default, allowing for an XSS attack. This issue affects: Drupal Drupal Core 7.x versions prior to 7.73; 8.8.x versions prior to 8.8.10; 8.9.x versions prior to 8.9.6; 9.0.x versions prior to 9.0.6.
Weakness: CWE-79
Which versions are affected by CVE-2020-13666?
18 open source packages ship an affected version, including drupal/core, drupal and drupal/drupal. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
drupal/core Packagist | From 7.0.0 | 7.73 |
drupal/core Packagist | From 7.0.0 | 7.73 |
drupal/core Packagist | From 8.0.0 | 8.8.10, 8.9.6, 9.0.6 |
drupal/core Packagist | From 8.8.0 | 8.8.10 |
drupal/core Packagist | From 8.8.0 | 8.8.10 |
drupal/core Packagist | From 8.9.0 | 8.9.6 |
12 more packages
drupal/core Packagist | From 8.9.0 | 8.9.6 |
drupal/core Packagist | From 9.0.0 | 9.0.6 |
drupal/core Packagist | From 9.0.0 | 9.0.6 |
drupal Bitnami | From 7.0.0 | 7.73.0, 8.8.10, 8.9.6, 9.0.6 |
drupal/drupal Packagist | From 7.0.0 | 7.73 |
drupal/drupal Packagist | From 7.0.0 | 7.73 |
drupal/drupal Packagist | From 8.8.0 | 8.8.10 |
drupal/drupal Packagist | From 8.8.0 | 8.8.10 |
drupal/drupal Packagist | From 8.9.0 | 8.9.6 |
drupal/drupal Packagist | From 8.9.0 | 8.9.6 |
drupal/drupal Packagist | From 9.0.0 | 9.0.6 |
drupal/drupal Packagist | From 9.0.0 | 9.0.6 |
Products include Drupal Drupal.
How do I fix CVE-2020-13666?
Upgrade drupal/core to a fixed version for your release line: 7.73, 8.8.10, 8.9.6 or 9.0.6.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2020-13666 being exploited?
There is no known exploitation of CVE-2020-13666 in the wild and no public exploit code.
Other vulnerabilities in Drupal Drupal
Sources
Also known as BIT-drupal-2020-13666, CLEANSTART-2024-AP37400, DRUPAL-CORE-2020-007, GHSA-8jj2-x2gc-ggm7, UBUNTU-CVE-2020-13666.