CVE-2020-13667 Drupal Core Access bypass vulnerability
Attackers can bypass permissions to view unpublished content in Drupal if the experimental Workspaces module is enabled.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-13667?
CVE-2020-13667 is a medium-severity missing authorization vulnerability in Drupal Drupal, published on 17 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Access bypass vulnerability in of Drupal Core Workspaces allows an attacker to access data without correct permissions. The Workspaces module doesn't sufficiently check access permissions when switching workspaces, leading to an access bypass vulnerability. An attacker might be able to see content before the site owner intends people to see the content. This vulnerability is mitigated by the fact that sites are only vulnerable if they have installed the experimental Workspaces module. This issue affects Drupal Core8.8.X versions prior to 8.8.10; 8.9.X versions prior to 8.9.6; 9.0.X versions prior to 9.0.6.
Weakness: CWE-276
Which versions are affected by CVE-2020-13667?
14 open source packages ship an affected version, including drupal/core, drupal and drupal/drupal. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
drupal/core Packagist | From 8.0.0 | 8.8.10, 8.9.6, 9.0.6 |
drupal/core Packagist | From 8.8.0 | 8.8.10 |
drupal/core Packagist | From 8.8.0 | 8.8.10 |
drupal/core Packagist | From 8.9.0 | 8.9.6 |
drupal/core Packagist | From 8.9.0 | 8.9.6 |
drupal/core Packagist | From 9.0.0 | 9.0.6 |
8 more packages
drupal/core Packagist | From 9.0.0 | 9.0.6 |
drupal Bitnami | From 8.8.0 | 8.8.10, 8.9.6, 9.0.6 |
drupal/drupal Packagist | From 8.8.0 | 8.8.10 |
drupal/drupal Packagist | From 8.8.0 | 8.8.10 |
drupal/drupal Packagist | From 8.9.0 | 8.9.6 |
drupal/drupal Packagist | From 8.9.0 | 8.9.6 |
drupal/drupal Packagist | From 9.0.0 | 9.0.6 |
drupal/drupal Packagist | From 9.0.0 | 9.0.6 |
Products include Drupal Drupal.
How do I fix CVE-2020-13667?
Upgrade drupal/core to a fixed version for your release line: 8.8.10, 8.9.6 or 9.0.6.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2020-13667 being exploited?
There is no known exploitation of CVE-2020-13667 in the wild and no public exploit code.
Other vulnerabilities in Drupal Drupal
Sources
Also known as BIT-drupal-2020-13667, DRUPAL-CORE-2020-008, GHSA-x2q9-r8gm-f657.