# CVE-2020-13667: Drupal Core Access bypass vulnerability

> Attackers can bypass permissions to view unpublished content in Drupal if the experimental Workspaces module is enabled.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 May 2021
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-drupal-2020-13667, DRUPAL-CORE-2020-008, GHSA-x2q9-r8gm-f657

## What is CVE-2020-13667?

CVE-2020-13667 is a medium-severity missing authorization vulnerability in Drupal Drupal, published on 17 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Access bypass vulnerability in of Drupal Core Workspaces allows an attacker to access data without correct permissions. The Workspaces module doesn't sufficiently check access permissions when switching workspaces, leading to an access bypass vulnerability. An attacker might be able to see content before the site owner intends people to see the content. This vulnerability is mitigated by the fact that sites are only vulnerable if they have installed the experimental Workspaces module. This issue affects Drupal Core8.8.X versions prior to 8.8.10; 8.9.X versions prior to 8.9.6; 9.0.X versions prior to 9.0.6.

Weakness: CWE-276 (Incorrect Default Permissions)

## Which versions are affected by CVE-2020-13667?

14 open source packages ship an affected version, including drupal/core, drupal and drupal/drupal. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `drupal/core` | Packagist | From 8.0.0 | 8.8.10, 8.9.6, 9.0.6 |
| `drupal/core` | Packagist | From 8.8.0 | 8.8.10 |
| `drupal/core` | Packagist | From 8.8.0 | 8.8.10 |
| `drupal/core` | Packagist | From 8.9.0 | 8.9.6 |
| `drupal/core` | Packagist | From 8.9.0 | 8.9.6 |
| `drupal/core` | Packagist | From 9.0.0 | 9.0.6 |
| `drupal/core` | Packagist | From 9.0.0 | 9.0.6 |
| `drupal` | Bitnami | From 8.8.0 | 8.8.10, 8.9.6, 9.0.6 |
| `drupal/drupal` | Packagist | From 8.8.0 | 8.8.10 |
| `drupal/drupal` | Packagist | From 8.8.0 | 8.8.10 |
| `drupal/drupal` | Packagist | From 8.9.0 | 8.9.6 |
| `drupal/drupal` | Packagist | From 8.9.0 | 8.9.6 |
| `drupal/drupal` | Packagist | From 9.0.0 | 9.0.6 |
| `drupal/drupal` | Packagist | From 9.0.0 | 9.0.6 |

Products: Drupal Drupal.

## How do I fix CVE-2020-13667?

Upgrade drupal/core to a fixed version for your release line: 8.8.10, 8.9.6 or 9.0.6.

## Is CVE-2020-13667 being exploited?

There is no known exploitation of CVE-2020-13667 in the wild and no public exploit code.

## Other vulnerabilities in Drupal Drupal

- [CVE-2026-9082](https://insights.sbomify.com/CVE-2026-9082/): Drupal Core SQL Injection (critical 9.8, exploited in the wild)
- [CVE-2020-13671](https://insights.sbomify.com/CVE-2020-13671/): Drupal core Un-restricted Upload of File (high 8.8, exploited in the wild)
- [CVE-2019-6340](https://insights.sbomify.com/CVE-2019-6340/): Drupal Core Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2009-3352](https://insights.sbomify.com/CVE-2009-3352/): Other in n/a (critical 10.0)
- [CVE-2024-55636](https://insights.sbomify.com/CVE-2024-55636/): Drupal core - Less critical - Gadget chain - SA-CORE-2024-006 (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-13667 and fix it if it is affected.

What it is: CVE-2020-13667 is a medium-severity missing authorization vulnerability in Drupal Drupal, published on 17 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-13667 in the wild and no public exploit code.

Affected packages and fixed versions:
- drupal/core (Packagist): affected from 8.0.0; fixed in 8.8.10, 8.9.6, 9.0.6
- drupal/core (Packagist): affected from 8.8.0; fixed in 8.8.10
- drupal/core (Packagist): affected from 8.8.0; fixed in 8.8.10
- drupal/core (Packagist): affected from 8.9.0; fixed in 8.9.6
- drupal/core (Packagist): affected from 8.9.0; fixed in 8.9.6
- drupal/core (Packagist): affected from 9.0.0; fixed in 9.0.6
- drupal/core (Packagist): affected from 9.0.0; fixed in 9.0.6
- drupal (Bitnami): affected from 8.8.0; fixed in 8.8.10, 8.9.6, 9.0.6
- drupal/drupal (Packagist): affected from 8.8.0; fixed in 8.8.10
- drupal/drupal (Packagist): affected from 8.8.0; fixed in 8.8.10
- drupal/drupal (Packagist): affected from 8.9.0; fixed in 8.9.6
- drupal/drupal (Packagist): affected from 8.9.0; fixed in 8.9.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-13667/ (Markdown: https://insights.sbomify.com/CVE-2020-13667/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-13667
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-13667
- OSV: https://osv.dev/vulnerability/CVE-2020-13667

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-13667/
Summaries are generated and may contain mistakes; the official description above is the record.
