CVE-2020-13670 Exposure of Resource to Wrong Sphere in Drupal Core
Attackers can access metadata of private files by guessing IDs, exposing sensitive information in Drupal Core installations.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-13670?
CVE-2020-13670 is a high-severity vulnerability in Drupal Drupal, published on 11 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Information Disclosure vulnerability in file module of Drupal Core allows an attacker to gain access to the file metadata of a permanent private file that they do not have access to by guessing the ID of the file. This issue affects: Drupal Core 8.8.x versions prior to 8.8.10; 8.9.x versions prior to 8.9.6; 9.0.x versions prior to 9.0.6.
Weakness: CWE-668
Which versions are affected by CVE-2020-13670?
14 open source packages ship an affected version, including drupal/core, drupal and drupal/drupal. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
drupal/core Packagist | From 8.0.0 | 8.8.10, 8.9.6, 9.0.6 |
drupal/core Packagist | From 8.0.0 | 8.8.10 |
drupal/core Packagist | From 8.0.0 | 8.8.10 |
drupal/core Packagist | From 8.9.0 | 8.9.6 |
drupal/core Packagist | From 8.9.0 | 8.9.6 |
drupal/core Packagist | From 9.0.0 | 9.0.6 |
8 more packages
drupal/core Packagist | From 9.0.0 | 9.0.6 |
drupal Bitnami | From 8.8.0 | 8.8.10, 8.9.6, 9.0.6 |
drupal/drupal Packagist | From 8.0.0 | 8.8.10 |
drupal/drupal Packagist | From 8.0.0 | 8.8.10 |
drupal/drupal Packagist | From 8.9.0 | 8.9.6 |
drupal/drupal Packagist | From 8.9.0 | 8.9.6 |
drupal/drupal Packagist | From 9.0.0 | 9.0.6 |
drupal/drupal Packagist | From 9.0.0 | 9.0.6 |
Products include Drupal Drupal.
How do I fix CVE-2020-13670?
Upgrade drupal/core to a fixed version for your release line: 8.8.10, 8.9.6 or 9.0.6.
Is CVE-2020-13670 being exploited?
There is no known exploitation of CVE-2020-13670 in the wild and no public exploit code.
Other vulnerabilities in Drupal Drupal
Sources
Also known as BIT-drupal-2020-13670, DRUPAL-CORE-2020-011, GHSA-mmjr-5q74-p3m4.