CVE-2020-13671 Drupal core Un-restricted Upload of File
Attackers can upload malicious files that are executed as PHP due to improper filename sanitization in specific hosting configurations.
- Exploited in the wild
- Since 18 Jan 2022
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-13671?
CVE-2020-13671 is a high-severity vulnerability in Drupal Drupal, published on 20 Nov 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Drupal core does not properly sanitize certain filenames on uploaded files, which can lead to files being interpreted as the incorrect extension and served as the wrong MIME type or executed as PHP for certain hosting configurations. This issue affects: Drupal Drupal Core 9.0 versions prior to 9.0.8, 8.9 versions prior to 8.9.9, 8.8 versions prior to 8.8.11, and 7 versions prior to 7.74.
Weakness: CWE-434
Which versions are affected by CVE-2020-13671?
18 open source packages ship an affected version, including drupal/core, drupal and drupal/drupal. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
drupal/core Packagist | From 7.0.0 | 7.74 |
drupal/core Packagist | From 7.0.0 | 7.74 |
drupal/core Packagist | From 8.0.0 | 8.8.11, 8.9.9, 9.0.8 |
drupal/core Packagist | From 8.0.0 | 8.8.11 |
drupal/core Packagist | From 8.0.0 | 8.8.11 |
drupal/core Packagist | From 8.9.0 | 8.9.9 |
12 more packages
drupal/core Packagist | From 8.9.0 | 8.9.9 |
drupal/core Packagist | From 9.0.0 | 9.0.8 |
drupal/core Packagist | From 9.0.0 | 9.0.8 |
drupal Bitnami | From 7.0.0 | 7.74.0, 8.8.11, 8.9.9, 9.0.8 |
drupal/drupal Packagist | From 7.0.0 | 7.74 |
drupal/drupal Packagist | From 7.0.0 | 7.74 |
drupal/drupal Packagist | From 8.0.0 | 8.8.11 |
drupal/drupal Packagist | From 8.0.0 | 8.8.11 |
drupal/drupal Packagist | From 8.9.0 | 8.9.9 |
drupal/drupal Packagist | From 8.9.0 | 8.9.9 |
drupal/drupal Packagist | From 9.0.0 | 9.0.8 |
drupal/drupal Packagist | From 9.0.0 | 9.0.8 |
Products include Drupal Drupal, Fedoraproject Fedora.
How do I fix CVE-2020-13671?
Upgrade drupal/core to a fixed version for your release line: 7.74, 8.8.11, 8.9.9 or 9.0.8. US federal agencies must fix it by 18 Jul 2022.
Is CVE-2020-13671 being exploited?
Yes. Attackers have exploited CVE-2020-13671 in the wild since at least 18 Jan 2022.
Public exploit code: 3 proofs of concept on GitHub.
Other vulnerabilities in Drupal Drupal
Sources
Also known as BIT-drupal-2020-13671, DRUPAL-CORE-2020-012, GHSA-68jc-v27h-vhmw, UBUNTU-CVE-2020-13671.