# CVE-2020-13671: Drupal core Un-restricted Upload of File

> Attackers can upload malicious files that are executed as PHP due to improper filename sanitization in specific hosting configurations.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Yes, since 18 Jan 2022 (CISA KEV)
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Nov 2020
- **Updated:** 21 Oct 2025
- **Also known as:** BIT-drupal-2020-13671, DRUPAL-CORE-2020-012, GHSA-68jc-v27h-vhmw, UBUNTU-CVE-2020-13671

## What is CVE-2020-13671?

CVE-2020-13671 is a high-severity vulnerability in Drupal Drupal, published on 20 Nov 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Drupal core does not properly sanitize certain filenames on uploaded files, which can lead to files being interpreted as the incorrect extension and served as the wrong MIME type or executed as PHP for certain hosting configurations. This issue affects: Drupal Drupal Core 9.0 versions prior to 9.0.8, 8.9 versions prior to 8.9.9, 8.8 versions prior to 8.8.11, and 7 versions prior to 7.74.

Weakness: CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2020-13671?

18 open source packages ship an affected version, including drupal/core, drupal and drupal/drupal. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `drupal/core` | Packagist | From 7.0.0 | 7.74 |
| `drupal/core` | Packagist | From 7.0.0 | 7.74 |
| `drupal/core` | Packagist | From 8.0.0 | 8.8.11, 8.9.9, 9.0.8 |
| `drupal/core` | Packagist | From 8.0.0 | 8.8.11 |
| `drupal/core` | Packagist | From 8.0.0 | 8.8.11 |
| `drupal/core` | Packagist | From 8.9.0 | 8.9.9 |
| `drupal/core` | Packagist | From 8.9.0 | 8.9.9 |
| `drupal/core` | Packagist | From 9.0.0 | 9.0.8 |
| `drupal/core` | Packagist | From 9.0.0 | 9.0.8 |
| `drupal` | Bitnami | From 7.0.0 | 7.74.0, 8.8.11, 8.9.9, 9.0.8 |
| `drupal/drupal` | Packagist | From 7.0.0 | 7.74 |
| `drupal/drupal` | Packagist | From 7.0.0 | 7.74 |
| `drupal/drupal` | Packagist | From 8.0.0 | 8.8.11 |
| `drupal/drupal` | Packagist | From 8.0.0 | 8.8.11 |
| `drupal/drupal` | Packagist | From 8.9.0 | 8.9.9 |
| `drupal/drupal` | Packagist | From 8.9.0 | 8.9.9 |
| `drupal/drupal` | Packagist | From 9.0.0 | 9.0.8 |
| `drupal/drupal` | Packagist | From 9.0.0 | 9.0.8 |

Products: Drupal Drupal, Fedoraproject Fedora.

## How do I fix CVE-2020-13671?

Upgrade drupal/core to a fixed version for your release line: 7.74, 8.8.11, 8.9.9 or 9.0.8. US federal agencies must fix it by 18 Jul 2022.

## Is CVE-2020-13671 being exploited?

Yes. Attackers have exploited CVE-2020-13671 in the wild since at least 18 Jan 2022.

Public exploit code:

- CVE-2020-13671 - Drupal RCE via File Upload Vulnerability Analysis and PoC (github_poc): https://github.com/Dungsocool/CVE-2020-13671-old
- CVE-2020-13671 - Drupal RCE via File Upload Vulnerability Analysis and PoC (github_poc): https://github.com/Dungsocool/CVE-2020-13671
- https://github.com/ivanesk315/CVE-2020-13671 (github_poc): https://github.com/ivanesk315/CVE-2020-13671

## Other vulnerabilities in Drupal Drupal

- [CVE-2026-9082](https://insights.sbomify.com/CVE-2026-9082/): Drupal Core SQL Injection (critical 9.8, exploited in the wild)
- [CVE-2019-6340](https://insights.sbomify.com/CVE-2019-6340/): Drupal Core Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2009-3352](https://insights.sbomify.com/CVE-2009-3352/): Other in n/a (critical 10.0)
- [CVE-2024-55636](https://insights.sbomify.com/CVE-2024-55636/): Drupal core - Less critical - Gadget chain - SA-CORE-2024-006 (critical 9.8)
- [CVE-2024-55637](https://insights.sbomify.com/CVE-2024-55637/): Drupal core - Moderately critical - Gadget chain - SA-CORE-2024-007 (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-13671 and fix it if it is affected.

What it is: CVE-2020-13671 is a high-severity vulnerability in Drupal Drupal, published on 20 Nov 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: Yes. Attackers have exploited CVE-2020-13671 in the wild since at least 18 Jan 2022.

Affected packages and fixed versions:
- drupal/core (Packagist): affected from 7.0.0; fixed in 7.74
- drupal/core (Packagist): affected from 7.0.0; fixed in 7.74
- drupal/core (Packagist): affected from 8.0.0; fixed in 8.8.11, 8.9.9, 9.0.8
- drupal/core (Packagist): affected from 8.0.0; fixed in 8.8.11
- drupal/core (Packagist): affected from 8.0.0; fixed in 8.8.11
- drupal/core (Packagist): affected from 8.9.0; fixed in 8.9.9
- drupal/core (Packagist): affected from 8.9.0; fixed in 8.9.9
- drupal/core (Packagist): affected from 9.0.0; fixed in 9.0.8
- drupal/core (Packagist): affected from 9.0.0; fixed in 9.0.8
- drupal (Bitnami): affected from 7.0.0; fixed in 7.74.0, 8.8.11, 8.9.9, 9.0.8
- drupal/drupal (Packagist): affected from 7.0.0; fixed in 7.74
- drupal/drupal (Packagist): affected from 7.0.0; fixed in 7.74

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-13671/ (Markdown: https://insights.sbomify.com/CVE-2020-13671/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-13671
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-13671
- OSV: https://osv.dev/vulnerability/CVE-2020-13671

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-13671/
Summaries are generated and may contain mistakes; the official description above is the record.
