CVE-2020-13672 Drupal core Cross-site Scripting (XSS) vulnerability
Drupal core's sanitization API fails to filter XSS, allowing attackers to inject scripts and potentially compromise user accounts.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2020-13672?
CVE-2020-13672 is a medium-severity cross-site scripting vulnerability in Drupal Drupal, published on 11 Feb 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Cross-site Scripting (XSS) vulnerability in Drupal core's sanitization API fails to properly filter cross-site scripting under certain circumstances. This issue affects: Drupal Core 9.1.x versions prior to 9.1.7; 9.0.x versions prior to 9.0.12; 8.9.x versions prior to 8.9.14; 7.x versions prior to 7.80.
Weakness: CWE-79
Which versions are affected by CVE-2020-13672?
18 open source packages ship an affected version, including drupal/core, drupal and drupal/drupal. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
drupal/core Packagist | From 7.0.0 | 7.80 |
drupal/core Packagist | From 7.0.0 | 7.80 |
drupal/core Packagist | From 8.0.0 | 8.9.14, 9.0.12, 9.1.7 |
drupal/core Packagist | From 8.0.0 | 8.9.14 |
drupal/core Packagist | From 8.0.0 | 8.9.14 |
drupal/core Packagist | From 9.0.0 | 9.0.12 |
12 more packages
drupal/core Packagist | From 9.0.0 | 9.0.12 |
drupal/core Packagist | From 9.1.0 | 9.1.7 |
drupal/core Packagist | From 9.1.0 | 9.1.7 |
drupal Bitnami | All versions | 7.80.0, 8.9.14, 9.0.12, 9.1.7 |
drupal/drupal Packagist | From 7.0.0 | 7.80 |
drupal/drupal Packagist | From 7.0.0 | 7.80 |
drupal/drupal Packagist | From 8.0.0 | 8.9.14 |
drupal/drupal Packagist | From 8.0.0 | 8.9.14 |
drupal/drupal Packagist | From 9.0.0 | 9.0.12 |
drupal/drupal Packagist | From 9.0.0 | 9.0.12 |
drupal/drupal Packagist | From 9.1.0 | 9.1.7 |
drupal/drupal Packagist | From 9.1.0 | 9.1.7 |
Products include Drupal Drupal.
How do I fix CVE-2020-13672?
Upgrade drupal/core to a fixed version for your release line: 7.80, 8.9.14, 9.0.12 or 9.1.7.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2020-13672 being exploited?
There is no known exploitation of CVE-2020-13672 in the wild and no public exploit code.
Other vulnerabilities in Drupal Drupal
Sources
Also known as BIT-drupal-2020-13672, CLEANSTART-2024-CD56288, DLA-2637-1, DRUPAL-CORE-2021-002, GHSA-3m36-mjwj-352c, UBUNTU-CVE-2020-13672.