CVE-2020-13756 Sabberworm PHP CSS Parser Code injection vulnerability in allSelectors()
Attacker can execute arbitrary code via eval on uncontrolled data in Sabberworm PHP CSS Parser when specific selector functions are called.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-13756?
CVE-2020-13756 is a critical code injection vulnerability in n/a, published on 3 Jun 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Sabberworm PHP CSS Parser before 8.3.1 calls eval on uncontrolled data, possibly leading to remote code execution if the function allSelectors() or getSelectorsBySpecificity() is called with input from an attacker.
Weakness: CWE-94
Which versions are affected by CVE-2020-13756?
26 open source packages ship an affected version, including sabberworm/php-css-parser. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
sabberworm/php-css-parser Packagist | From 1.0.0 | 1.0.1 |
sabberworm/php-css-parser Packagist | From 1.0.0 | 1.0.1 |
sabberworm/php-css-parser Packagist | From 2.0.0 | 2.0.1 |
sabberworm/php-css-parser Packagist | From 2.0.0 | 2.0.1 |
sabberworm/php-css-parser Packagist | From 3.0.0 | 3.0.1 |
sabberworm/php-css-parser Packagist | From 3.0.0 | 3.0.1 |
20 more packages
sabberworm/php-css-parser Packagist | From 4.0.0 | 4.0.1 |
sabberworm/php-css-parser Packagist | From 4.0.0 | 4.0.1 |
sabberworm/php-css-parser Packagist | From 5.0.0 | 5.0.9 |
sabberworm/php-css-parser Packagist | From 5.0.0 | 5.0.9 |
sabberworm/php-css-parser Packagist | From 5.1.0 | 5.1.3 |
sabberworm/php-css-parser Packagist | From 5.1.0 | 5.1.3 |
sabberworm/php-css-parser Packagist | From 5.2.0 | 5.2.1 |
sabberworm/php-css-parser Packagist | From 5.2.0 | 5.2.1 |
sabberworm/php-css-parser Packagist | From 6.0.0 | 6.0.2 |
sabberworm/php-css-parser Packagist | From 6.0.0 | 6.0.2 |
sabberworm/php-css-parser Packagist | From 7.0.0 | 7.0.4 |
sabberworm/php-css-parser Packagist | From 7.0.0 | 7.0.4 |
sabberworm/php-css-parser Packagist | From 8.0.0 | 8.0.1 |
sabberworm/php-css-parser Packagist | From 8.0.0 | 8.0.1 |
sabberworm/php-css-parser Packagist | From 8.1.0 | 8.1.1 |
sabberworm/php-css-parser Packagist | From 8.1.0 | 8.1.1 |
sabberworm/php-css-parser Packagist | From 8.2.0 | 8.2.1 |
sabberworm/php-css-parser Packagist | From 8.2.0 | 8.2.1 |
sabberworm/php-css-parser Packagist | From 8.3.0 | 8.3.1 |
sabberworm/php-css-parser Packagist | From 8.3.0 | 8.3.1 |
Products include Sabberworm Php Css Parser.
How do I fix CVE-2020-13756?
Upgrade sabberworm/php-css-parser to a fixed version for your release line: 1.0.1, 2.0.1, 3.0.1 or 4.0.1.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2020-13756 being exploited?
There is no known exploitation of CVE-2020-13756 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Sources
Also known as DEBIAN-CVE-2020-13756, DLA-4333-1, GHSA-phrq-v4q2-hmq6, UBUNTU-CVE-2020-13756, USN-7502-1.