# CVE-2020-13764: Gravity Forms plugin leak hashed passwords

> Attackers can retrieve hashed user passwords from Gravity Forms plugin due to improper property access handling.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Jun 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-m983-q76g-cwpq

## What is CVE-2020-13764?

CVE-2020-13764 is a high-severity vulnerability in n/a, published on 2 Jun 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

common.php in the Gravity Forms plugin before 2.4.9 for WordPress can leak hashed passwords because user_pass is not considered a special case for a $current_user->get($property) call.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2020-13764?

2 open source packages ship an affected version, including wp-premium/gravityforms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wp-premium/gravityforms` | Packagist | All versions | 2.4.9 |
| `wp-premium/gravityforms` | Packagist | All versions | 2.4.9 |

Products: Rocketgenius Gravityforms.

## How do I fix CVE-2020-13764?

Upgrade wp-premium/gravityforms to 2.4.9 or later.

## Is CVE-2020-13764 being exploited?

There is no known exploitation of CVE-2020-13764 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2020-27851](https://insights.sbomify.com/CVE-2020-27851/): Gravity Forms stored HTML injection vulnerability (medium 5.4)
- [CVE-2020-27852](https://insights.sbomify.com/CVE-2020-27852/): Gravity Forms stored Cross-Site Scripting (XSS) vulnerability in the survey feature (medium 5.4)
- [CVE-2020-27850](https://insights.sbomify.com/CVE-2020-27850/): Gravity Forms stored Cross-Site Scripting (XSS) vulnerability (medium 4.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-13764 and fix it if it is affected.

What it is: CVE-2020-13764 is a high-severity vulnerability in n/a, published on 2 Jun 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-13764 in the wild and no public exploit code.

Affected packages and fixed versions:
- wp-premium/gravityforms (Packagist): affected all versions; fixed in 2.4.9
- wp-premium/gravityforms (Packagist): affected all versions; fixed in 2.4.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-13764/ (Markdown: https://insights.sbomify.com/CVE-2020-13764/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-13764
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-13764
- OSV: https://osv.dev/vulnerability/CVE-2020-13764

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-13764/
Summaries are generated and may contain mistakes; the official description above is the record.
