# CVE-2020-13827: Cross-site scripting in n/a

> Cross-site scripting vulnerability in phpList allows attackers to inject malicious scripts via admin user pages, potentially leading to session hijacking or code execution.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Jun 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-phplist-2020-13827, GHSA-f969-r685-p3gx

## What is CVE-2020-13827?

CVE-2020-13827 is a medium-severity cross-site scripting vulnerability in n/a, published on 4 Jun 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

phpList before 3.5.4 allows XSS via /lists/admin/user.php and /lists/admin/users.php.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-13827?

1 open source package ship an affected version, including phplist. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phplist` | Bitnami | All versions | 3.5.4 |

Products: Phplist Phplist.

## How do I fix CVE-2020-13827?

Upgrade phplist to 3.5.4 or later.

## Is CVE-2020-13827 being exploited?

There is no known exploitation of CVE-2020-13827 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2020-22249](https://insights.sbomify.com/CVE-2020-22249/): File upload in n/a (critical 9.8)
- [CVE-2020-23361](https://insights.sbomify.com/CVE-2020-23361/): Auth bypass in n/a (critical 9.8)
- [CVE-2021-3188](https://insights.sbomify.com/CVE-2021-3188/): Other in n/a (critical 9.8)
- [CVE-2020-8547](https://insights.sbomify.com/CVE-2020-8547/): Auth bypass in n/a (critical 9.8)
- [CVE-2020-15072](https://insights.sbomify.com/CVE-2020-15072/): SQL injection in n/a (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-13827 and fix it if it is affected.

What it is: CVE-2020-13827 is a medium-severity cross-site scripting vulnerability in n/a, published on 4 Jun 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-13827 in the wild and no public exploit code.

Affected packages and fixed versions:
- phplist (Bitnami): affected all versions; fixed in 3.5.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-13827/ (Markdown: https://insights.sbomify.com/CVE-2020-13827/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-13827
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-13827
- OSV: https://osv.dev/vulnerability/CVE-2020-13827

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-13827/
Summaries are generated and may contain mistakes; the official description above is the record.
