# CVE-2020-13869: Comments plugin stored Cross-site Scripting via a guest name

> Stored XSS in Craft CMS Comments plugin allows attackers to inject scripts via guest names, potentially compromising user sessions.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 5 Jun 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-jhhf-c849-3rh2

## What is CVE-2020-13869?

CVE-2020-13869 is a medium-severity cross-site scripting vulnerability in n/a, published on 5 Jun 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

An issue was discovered in the Comments plugin before 1.5.6 for Craft CMS. There is stored XSS via a guest name.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-13869?

2 open source packages ship an affected version, including verbb/comments. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `verbb/comments` | Packagist | All versions | 1.5.5 |
| `verbb/comments` | Packagist | All versions | 1.5.5 |

Products: Verbb Comments.

## How do I fix CVE-2020-13869?

Upgrade verbb/comments to 1.5.5 or later.

## Is CVE-2020-13869 being exploited?

There is no known exploitation of CVE-2020-13869 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2020-13868](https://insights.sbomify.com/CVE-2020-13868/): Comments plugin Cross-Site Request Forgery (CSRF) (medium 6.5)
- [CVE-2020-13870](https://insights.sbomify.com/CVE-2020-13870/): Comments plugin stored Cross-site Scripting (XSS) via an asset volume name (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-13869 and fix it if it is affected.

What it is: CVE-2020-13869 is a medium-severity cross-site scripting vulnerability in n/a, published on 5 Jun 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-13869 in the wild and no public exploit code.

Affected packages and fixed versions:
- verbb/comments (Packagist): affected all versions; fixed in 1.5.5
- verbb/comments (Packagist): affected all versions; fixed in 1.5.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-13869/ (Markdown: https://insights.sbomify.com/CVE-2020-13869/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-13869
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-13869
- OSV: https://osv.dev/vulnerability/CVE-2020-13869

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-13869/
Summaries are generated and may contain mistakes; the official description above is the record.
