CVE-2020-13909 Critical severity vulnerability in Ignition
The Laravel Ignition component improperly handles global variables, potentially allowing attackers to read sensitive environment and request data.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-13909?
CVE-2020-13909 is a critical vulnerability in n/a, published on 7 Jun 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The Ignition component before 2.0.5 for Laravel mishandles globals, _get, _post, _cookie, and _env. NOTE: in the 1.x series, versions 1.16.15 and later are unaffected as a consequence of the CVE-2021-43996 fix.
Which versions are affected by CVE-2020-13909?
4 open source packages ship an affected version, including facade/ignition. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
facade/ignition Packagist | All versions | 1.16.15 |
facade/ignition Packagist | All versions | 1.16.15 |
facade/ignition Packagist | From 2.0.0 | 2.0.5 |
facade/ignition Packagist | From 2.0.0 | 2.0.5 |
Products include Facade Ignition.
How do I fix CVE-2020-13909?
Upgrade facade/ignition to a fixed version for your release line: 1.16.15 or 2.0.5.
Is CVE-2020-13909 being exploited?
There is no known exploitation of CVE-2020-13909 in the wild and no public exploit code.
Other vulnerabilities in n/a
Sources
Also known as GHSA-m5v7-pr32-mjx2.