# CVE-2020-13920: Improper Authentication in Apache ActiveMQ

> An unauthenticated attacker can rebind the JMX RMI registry to intercept user credentials via a man-in-the-middle attack.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Sep 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-activemq-2020-13920, DEBIAN-CVE-2020-13920, DLA-2400-1, GHSA-xgrx-xpv2-6vp4, UBUNTU-CVE-2020-13920

## What is CVE-2020-13920?

CVE-2020-13920 is a medium-severity missing authorization vulnerability in Apache Activemq, published on 10 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache ActiveMQ uses LocateRegistry.createRegistry() to create the JMX RMI registry and binds the server to the "jmxrmi" entry. It is possible to connect to the registry without authentication and call the rebind method to rebind jmxrmi to something else. If an attacker creates another server to proxy the original, and bound that, he effectively becomes a man in the middle and is able to intercept the credentials when an user connects. Upgrade to Apache ActiveMQ 5.15.12.

Weakness: CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2020-13920?

3 open source packages ship an affected version, including org.apache.activemq:activemq-parent and activemq. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.activemq:activemq-parent` | Maven | All versions | 5.15.12 |
| `org.apache.activemq:activemq-parent` | Maven | All versions | 5.15.12 |
| `activemq` | Bitnami | All versions | 5.15.12 |

Products: Apache Activemq, Debian Debian Linux, Oracle Communications Diameter Signaling Router, Oracle Flexcube Private Banking.

## How do I fix CVE-2020-13920?

Upgrade org.apache.activemq:activemq-parent to 5.15.12 or later.

## Is CVE-2020-13920 being exploited?

There is no known exploitation of CVE-2020-13920 in the wild and no public exploit code.

## Other vulnerabilities in Apache Activemq

- [CVE-2023-46604](https://insights.sbomify.com/CVE-2023-46604/): Apache ActiveMQ Deserialization of Untrusted Data (critical 10.0, exploited in the wild)
- [CVE-2016-3088](https://insights.sbomify.com/CVE-2016-3088/): Apache ActiveMQ Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2026-34197](https://insights.sbomify.com/CVE-2026-34197/): Apache ActiveMQ Improper Input Validation (high 8.8, exploited in the wild)
- [CVE-2020-11998](https://insights.sbomify.com/CVE-2020-11998/): Remote code execution in Apache ActiveMQ (critical 9.8)
- [CVE-2013-7285](https://insights.sbomify.com/CVE-2013-7285/): Command Injection in Xstream (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-13920 and fix it if it is affected.

What it is: CVE-2020-13920 is a medium-severity missing authorization vulnerability in Apache Activemq, published on 10 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-13920 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.activemq:activemq-parent (Maven): affected all versions; fixed in 5.15.12
- org.apache.activemq:activemq-parent (Maven): affected all versions; fixed in 5.15.12
- activemq (Bitnami): affected all versions; fixed in 5.15.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-13920/ (Markdown: https://insights.sbomify.com/CVE-2020-13920/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-13920
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-13920
- OSV: https://osv.dev/vulnerability/CVE-2020-13920

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-13920/
Summaries are generated and may contain mistakes; the official description above is the record.
