CVE-2020-13925 Command Injection in Kylin

Critical 9.8 Published Updated

Remote attackers can execute arbitrary OS commands on Apache Kylin servers due to missing input validation in a RESTful API.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2020-13925?

CVE-2020-13925 is a critical command injection vulnerability in Apache Kylin, published on 14 Jul 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Similar to CVE-2020-1956, Kylin has one more restful API which concatenates the API inputs into OS commands and then executes them on the server; while the reported API misses necessary input validation, which causes the hackers to have the possibility to execute OS command remotely. Users of all previous versions after 2.3 should upgrade to 3.1.0.

Weakness: CWE-78

Which versions are affected by CVE-2020-13925?

2 open source packages ship an affected version, including org.apache.kylin:kylin-server-base. It affects 1 product.

PackageAffectedFixed in
org.apache.kylin:kylin-server-base MavenAll versions3.1.0
org.apache.kylin:kylin-server-base MavenAll versions3.1.0

Products include Apache Kylin.

How do I fix CVE-2020-13925?

Upgrade org.apache.kylin:kylin-server-base to 3.1.0 or later.

Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.

Is CVE-2020-13925 being exploited?

There is no known exploitation of CVE-2020-13925 in the wild and no public exploit code.

Public exploit code: 1 proofs of concept on GitHub.

Sources

Also known as GHSA-qwfw-gxx2-mmv2.

Is CVE-2020-13925 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free