{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.kylin:kylin-server-base. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-13925 in the wild and no public exploit code.","fix":"Upgrade org.apache.kylin:kylin-server-base to 3.1.0 or later.","what":"CVE-2020-13925 is a critical command injection vulnerability in Apache Kylin, published on 14 Jul 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-13925 and fix it if it is affected.\n\nWhat it is: CVE-2020-13925 is a critical command injection vulnerability in Apache Kylin, published on 14 Jul 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-13925 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.kylin:kylin-server-base (Maven): affected all versions; fixed in 3.1.0\n- org.apache.kylin:kylin-server-base (Maven): affected all versions; fixed in 3.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-13925/ (Markdown: https://insights.sbomify.com/CVE-2020-13925/index.md)","id":"CVE-2020-13925","markdown":"https://insights.sbomify.com/CVE-2020-13925/index.md","name":"CVE-2020-13925","record":{"aliases":["GHSA-qwfw-gxx2-mmv2"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Kylin","requires_auth":"none","summary":"Remote attackers can execute arbitrary OS commands on Apache Kylin servers due to missing input validation in a RESTful API.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"kylin","vendor":"apache"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"Similar to CVE-2020-1956, Kylin has one more restful API which concatenates the API inputs into OS commands and then executes them on the server; while the reported API misses necessary input validation, which causes the hackers to have the possibility to execute OS command remotely. Users of all previous versions after 2.3 should upgrade to 3.1.0.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":"2020-07-20","github_poc":1,"max_poc_stars":16,"metasploit":0,"nuclei":0,"refs":[{"date":"2020-07-20T10:38:14Z","kind":"github_poc","ref":"https://github.com/bit4woo/CVE-2020-13925","stars":16,"title":null}],"tier":"poc_unverified"},"has_fix":true,"headline":"Command Injection in Kylin","id":"CVE-2020-13925","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"command_injection","year":"2020"},"n_packages":2,"n_references":2,"next":{"headline":"SQL Injection in Kylin","id":"CVE-2020-13926"},"packages":[{"ecosystem":"Maven","fixed":["3.1.0"],"introduced":["0"],"last_affected":[],"package":"org.apache.kylin:kylin-server-base","purl":null,"source":"GHSA-qwfw-gxx2-mmv2"},{"ecosystem":"Maven","fixed":["3.1.0"],"introduced":["0"],"last_affected":[],"package":"org.apache.kylin:kylin-server-base","purl":"pkg:maven/org.apache.kylin/kylin-server-base","source":"GHSA-qwfw-gxx2-mmv2"}],"prev":{"headline":"Path traversal in Apache Ambari","id":"CVE-2020-13924"},"products":["Apache Kylin"],"published":"2020-07-14","related":[{"cvss_score":8.8,"headline":"Apache Kylin OS Command Injection","id":"CVE-2020-1956","kev_date_added":"2022-03-25","published":"2020-05-22"},{"cvss_score":9.8,"headline":"Apache Kylin: SQL Injection Vulnerability in Catalog Cache Refresh API","id":"CVE-2026-62390","kev_date_added":null,"published":"2026-07-14"},{"cvss_score":9.8,"headline":"Apache Kylin: Command injection by Diagnosis Controller","id":"CVE-2022-44621","kev_date_added":null,"published":"2022-12-30"},{"cvss_score":9.8,"headline":"Apache Kylin vulnerable to remote code execution","id":"CVE-2022-24697","kev_date_added":null,"published":"2022-10-13"},{"cvss_score":9.8,"headline":"Apache Kylin unsafe class loading","id":"CVE-2021-31522","kev_date_added":null,"published":"2022-01-06"},{"cvss_score":9.8,"headline":"Command injection","id":"CVE-2021-45456","kev_date_added":null,"published":"2022-01-06"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary OS commands on Apache Kylin servers due to missing input validation in a RESTful API.","url":"https://insights.sbomify.com/CVE-2020-13925/"}