# CVE-2020-13925: Command Injection in Kylin

> Remote attackers can execute arbitrary OS commands on Apache Kylin servers due to missing input validation in a RESTful API.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Jul 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-qwfw-gxx2-mmv2

## What is CVE-2020-13925?

CVE-2020-13925 is a critical command injection vulnerability in Apache Kylin, published on 14 Jul 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Similar to CVE-2020-1956, Kylin has one more restful API which concatenates the API inputs into OS commands and then executes them on the server; while the reported API misses necessary input validation, which causes the hackers to have the possibility to execute OS command remotely. Users of all previous versions after 2.3 should upgrade to 3.1.0.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2020-13925?

2 open source packages ship an affected version, including org.apache.kylin:kylin-server-base. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.kylin:kylin-server-base` | Maven | All versions | 3.1.0 |
| `org.apache.kylin:kylin-server-base` | Maven | All versions | 3.1.0 |

Products: Apache Kylin.

## How do I fix CVE-2020-13925?

Upgrade org.apache.kylin:kylin-server-base to 3.1.0 or later.

## Is CVE-2020-13925 being exploited?

There is no known exploitation of CVE-2020-13925 in the wild and no public exploit code.

Public exploit code:

- https://github.com/bit4woo/CVE-2020-13925 (github_poc): https://github.com/bit4woo/CVE-2020-13925

## Other vulnerabilities in Apache Kylin

- [CVE-2020-1956](https://insights.sbomify.com/CVE-2020-1956/): Apache Kylin OS Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-62390](https://insights.sbomify.com/CVE-2026-62390/): Apache Kylin: SQL Injection Vulnerability in Catalog Cache Refresh API (critical 9.8)
- [CVE-2022-44621](https://insights.sbomify.com/CVE-2022-44621/): Apache Kylin: Command injection by Diagnosis Controller (critical 9.8)
- [CVE-2022-24697](https://insights.sbomify.com/CVE-2022-24697/): Apache Kylin vulnerable to remote code execution (critical 9.8)
- [CVE-2021-31522](https://insights.sbomify.com/CVE-2021-31522/): Apache Kylin unsafe class loading (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-13925 and fix it if it is affected.

What it is: CVE-2020-13925 is a critical command injection vulnerability in Apache Kylin, published on 14 Jul 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-13925 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.kylin:kylin-server-base (Maven): affected all versions; fixed in 3.1.0
- org.apache.kylin:kylin-server-base (Maven): affected all versions; fixed in 3.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-13925/ (Markdown: https://insights.sbomify.com/CVE-2020-13925/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-13925
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-13925
- OSV: https://osv.dev/vulnerability/CVE-2020-13925

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-13925/
Summaries are generated and may contain mistakes; the official description above is the record.
