# CVE-2020-13926: SQL Injection in Kylin


- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 14 Jul 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-hx5g-8hq2-8x4w

## What is CVE-2020-13926?

CVE-2020-13926 is a critical vulnerability in Apache Kylin, published on 14 Jul 2020. 

### Official description

Kylin concatenates and executes a Hive SQL in Hive CLI or beeline when building a new segment; some part of the HQL is from system configurations, while the configuration can be overwritten by certain rest api, which makes SQL injection attack is possible. Users of all previous versions after 2.0 should upgrade to 3.1.0.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2020-13926?

2 open source packages ship an affected version, including org.apache.kylin:kylin-server-base. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.kylin:kylin-server-base` | Maven | All versions | 3.1.0 |
| `org.apache.kylin:kylin-server-base` | Maven | All versions | 3.1.0 |

Products: Apache Kylin.

## How do I fix CVE-2020-13926?

Upgrade org.apache.kylin:kylin-server-base to 3.1.0 or later.

## Is CVE-2020-13926 being exploited?

There is no known exploitation of CVE-2020-13926 in the wild and no public exploit code.

## Other vulnerabilities in Apache Kylin

- [CVE-2020-1956](https://insights.sbomify.com/CVE-2020-1956/): Apache Kylin OS Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-62390](https://insights.sbomify.com/CVE-2026-62390/): Apache Kylin: SQL Injection Vulnerability in Catalog Cache Refresh API (critical 9.8)
- [CVE-2022-44621](https://insights.sbomify.com/CVE-2022-44621/): Apache Kylin: Command injection by Diagnosis Controller (critical 9.8)
- [CVE-2022-24697](https://insights.sbomify.com/CVE-2022-24697/): Apache Kylin vulnerable to remote code execution (critical 9.8)
- [CVE-2021-31522](https://insights.sbomify.com/CVE-2021-31522/): Apache Kylin unsafe class loading (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-13926 and fix it if it is affected.

What it is: CVE-2020-13926 is a critical vulnerability in Apache Kylin, published on 14 Jul 2020. 
Exploitation: There is no known exploitation of CVE-2020-13926 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.kylin:kylin-server-base (Maven): affected all versions; fixed in 3.1.0
- org.apache.kylin:kylin-server-base (Maven): affected all versions; fixed in 3.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-13926/ (Markdown: https://insights.sbomify.com/CVE-2020-13926/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-13926
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-13926
- OSV: https://osv.dev/vulnerability/CVE-2020-13926

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-13926/
Summaries are generated and may contain mistakes; the official description above is the record.
