# CVE-2020-13927: Apache Airflow's Experimental API Authentication Bypass

> Apache Airflow's Experimental API allowed unauthenticated access by default, enabling attackers to read or modify data without credentials.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Yes, since 18 Jan 2022 (CISA KEV)
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Nov 2020
- **Updated:** 21 Oct 2025
- **Also known as:** BIT-airflow-2020-13927, GHSA-hhx9-p69v-cx2j, PYSEC-2020-18

## What is CVE-2020-13927?

CVE-2020-13927 is a critical missing authorization vulnerability in Apache Airflow, published on 10 Nov 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The previous default setting for Airflow's Experimental API was to allow all API requests without authentication, but this poses security risks to users who miss this fact. From Airflow 1.10.11 the default has been changed to deny all requests by default and is documented at https://airflow.apache.org/docs/1.10.11/security.html#api-authentication. Note this change fixes it for new installs but existing users need to change their config to default `[api]auth_backend = airflow.api.auth.backend.deny_all` as mentioned in the Updating Guide: https://github.com/apache/airflow/blob/1.10.11/UPDATING.md#experimental-api-will-deny-all-request-by-default

Weakness: CWE-306 (Missing Authentication for Critical Functionality), CWE-1188 (Initialization of a Resource with an Insecure Default), CWE-1056 (Invokable Control Element with Variadic Parameters)

## Which versions are affected by CVE-2020-13927?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow` | PyPI | All versions | 1.10.11 |
| `apache-airflow` | PyPI | All versions | 1.10.11 |
| `apache-airflow` | PyPI | All versions | 1.10.11 |
| `airflow` | Bitnami | All versions | 1.10.11 |

Products: Apache Airflow.

## How do I fix CVE-2020-13927?

Upgrade apache-airflow to 1.10.11 or later. US federal agencies must fix it by 18 Jul 2022.

## Is CVE-2020-13927 being exploited?

Yes. Attackers have exploited CVE-2020-13927 in the wild since at least 18 Jan 2022.

Public exploit code:

- Apache Airflow 1.10.10 - Example DAG Remote Code Execution (metasploit)
- Apache Airflow 1.10.10 - 'Example Dag' Remote Code Execution (exploitdb)
- Security case-study: reachability analysis PoE → fix → PoNE on Apache Airflow experimental-API unauthenticated access (CVE-2020-13927), real code reconstructed at historical commits. Demo only, not for use. (github_poc): https://github.com/ferralon-demo/airflow-experimental-api-rce
- Airflow Experimental <1.10.11 - REST API Auth Bypass (nuclei): http/cves/2020/CVE-2020-13927.yaml

## Other vulnerabilities in Apache Airflow

- [CVE-2020-11978](https://insights.sbomify.com/CVE-2020-11978/): Apache Airflow Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-33264](https://insights.sbomify.com/CVE-2026-33264/): Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize() (critical 9.8)
- [CVE-2023-25754](https://insights.sbomify.com/CVE-2023-25754/): Apache Airflow: Privilege escalation using airflow logs (critical 9.8)
- [CVE-2023-22884](https://insights.sbomify.com/CVE-2023-22884/): Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow (critical 9.8)
- [CVE-2022-38649](https://insights.sbomify.com/CVE-2022-38649/): Apache Airflow Pinot provider allowed Command Injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-13927 and fix it if it is affected.

What it is: CVE-2020-13927 is a critical missing authorization vulnerability in Apache Airflow, published on 10 Nov 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: Yes. Attackers have exploited CVE-2020-13927 in the wild since at least 18 Jan 2022.

Affected packages and fixed versions:
- apache-airflow (PyPI): affected all versions; fixed in 1.10.11
- apache-airflow (PyPI): affected all versions; fixed in 1.10.11
- apache-airflow (PyPI): affected all versions; fixed in 1.10.11
- airflow (Bitnami): affected all versions; fixed in 1.10.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-13927/ (Markdown: https://insights.sbomify.com/CVE-2020-13927/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-13927
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-13927
- OSV: https://osv.dev/vulnerability/CVE-2020-13927

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-13927/
Summaries are generated and may contain mistakes; the official description above is the record.
