# CVE-2020-13928: Cross-site scripting in Apache Atlas

> Attackers can inject malicious scripts via unsanitized search or rendering elements in Apache Atlas, potentially leading to session hijacking or code execution.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 Sep 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-h6xq-3h62-99qx

## What is CVE-2020-13928?

CVE-2020-13928 is a medium-severity cross-site scripting vulnerability in Apache Atlas, published on 16 Sep 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Apache Atlas before 2.1.0 contain a XSS vulnerability. While saving search or rendering elements values are not sanitized correctly and because of that it triggers the XSS vulnerability.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-13928?

2 open source packages ship an affected version, including org.apache.atlas:apache-atlas. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.atlas:apache-atlas` | Maven | All versions | 2.1.0 |
| `org.apache.atlas:apache-atlas` | Maven | All versions | 2.1.0 |

Products: Apache Atlas.

## How do I fix CVE-2020-13928?

Upgrade org.apache.atlas:apache-atlas to 2.1.0 or later.

## Is CVE-2020-13928 being exploited?

There is no known exploitation of CVE-2020-13928 in the wild and no public exploit code.

## Other vulnerabilities in Apache Atlas

- [CVE-2026-50622](https://insights.sbomify.com/CVE-2026-50622/): Apache Atlas: Missing Authorization on Admin Endpoints (high 8.8)
- [CVE-2022-34271](https://insights.sbomify.com/CVE-2022-34271/): Apache Atlas: zip path traversal in import functionality (high 8.8)
- [CVE-2026-40563](https://insights.sbomify.com/CVE-2026-40563/): Apache Atlas: Script injection allows access to unintended data (high 8.1)
- [CVE-2016-8752](https://insights.sbomify.com/CVE-2016-8752/): Path Traversal in Apache Atlas (high 7.5)
- [CVE-2017-3154](https://insights.sbomify.com/CVE-2017-3154/): Apache Atlas produces Stack trace in error response (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-13928 and fix it if it is affected.

What it is: CVE-2020-13928 is a medium-severity cross-site scripting vulnerability in Apache Atlas, published on 16 Sep 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-13928 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.atlas:apache-atlas (Maven): affected all versions; fixed in 2.1.0
- org.apache.atlas:apache-atlas (Maven): affected all versions; fixed in 2.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-13928/ (Markdown: https://insights.sbomify.com/CVE-2020-13928/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-13928
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-13928
- OSV: https://osv.dev/vulnerability/CVE-2020-13928

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-13928/
Summaries are generated and may contain mistakes; the official description above is the record.
