CVE-2020-13944 Apache Airflow Cross-site Scripting

Medium 6.1 Published Updated

Attackers can execute arbitrary scripts in the context of other users via the origin parameter in Apache Airflow endpoints.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2020-13944?

CVE-2020-13944 is a medium-severity cross-site scripting vulnerability in Apache Airflow, published on 17 Sep 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

In Apache Airflow < 1.10.12, the "origin" parameter passed to some of the endpoints like '/trigger' was vulnerable to XSS exploit.

Weakness: CWE-79

Which versions are affected by CVE-2020-13944?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.

PackageAffectedFixed in
apache-airflow PyPIAll versions1.10.12
apache-airflow PyPIAll versions1.10.12
apache-airflow PyPIAll versions1.10.12
airflow BitnamiAll versions1.10.15, 2.0.2

Products include Apache Airflow.

How do I fix CVE-2020-13944?

Upgrade apache-airflow to 1.10.12 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2020-13944 being exploited?

There is no known exploitation of CVE-2020-13944 in the wild and no public exploit code.

All Apache Airflow vulnerabilities

Sources

Also known as BIT-airflow-2020-13944, GHSA-4pwq-fj89-6rjc, PYSEC-2020-19.

Is CVE-2020-13944 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free