CVE-2020-13946 Man-in-the-middle attack in Apache Cassandra
Local attackers can intercept JMX credentials via RMI manipulation, enabling unauthorized access to the database interface.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-13946?
CVE-2020-13946 is a medium-severity vulnerability in Netapp Oncommand Insight, published on 1 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
In Apache Cassandra, all versions prior to 2.1.22, 2.2.18, 3.0.22, 3.11.8 and 4.0-beta2, it is possible for a local attacker without access to the Apache Cassandra process or configuration files to manipulate the RMI registry to perform a man-in-the-middle attack and capture user names and passwords used to access the JMX interface. The attacker can then use these credentials to access the JMX interface and perform unauthorised operations. Users should also be aware of CVE-2019-2684, a JRE vulnerability that enables this issue to be exploited remotely.
Weakness: CWE-668
Which versions are affected by CVE-2020-13946?
11 open source packages ship an affected version, including org.apache.cassandra:cassandra-all and cassandra. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.cassandra:cassandra-all Maven | From 2.1.0 | 2.1.12 |
org.apache.cassandra:cassandra-all Maven | From 2.1.0 | 2.1.12 |
org.apache.cassandra:cassandra-all Maven | From 2.2.0 | 2.2.18 |
org.apache.cassandra:cassandra-all Maven | From 2.2.0 | 2.2.18 |
org.apache.cassandra:cassandra-all Maven | From 3.0.0 | 3.0.22 |
org.apache.cassandra:cassandra-all Maven | From 3.0.0 | 3.0.22 |
5 more packages
org.apache.cassandra:cassandra-all Maven | From 3.11.0 | 3.11.8 |
org.apache.cassandra:cassandra-all Maven | From 3.11.0 | 3.11.8 |
org.apache.cassandra:cassandra-all Maven | From 4.0-beta1 | 4.0-beta2 |
org.apache.cassandra:cassandra-all Maven | From 4.0-beta1 | 4.0-beta2 |
cassandra Bitnami | All versions | 2.1.22, 2.2.18, 3.0.22, 3.11.8 |
Products include Apache Cassandra, Netapp Oncommand Insight.
How do I fix CVE-2020-13946?
Upgrade org.apache.cassandra:cassandra-all to a fixed version for your release line: 2.1.12, 2.2.18, 3.0.22 or 3.11.8.
Is CVE-2020-13946 being exploited?
There is no known exploitation of CVE-2020-13946 in the wild and no public exploit code.
Other vulnerabilities in Netapp Oncommand Insight
- CVE-2016-3427 Oracle Java SE and JRockit Unspecified
- CVE-2018-8016 Missing Authentication for Critical Function in Apache Cassandra
- CVE-2021-44521 Remote code execution for scripted UDFs
- CVE-2026-27314 Apache Cassandra: Privilege escalation via ADD IDENTITY authorization bypass
- CVE-2025-26467 Apache Cassandra: User with MODIFY permission on ALL KEYSPACES can escalate privileges to superuser via unsafe actions (4.0.16 only)
Sources
Also known as BIT-cassandra-2020-13946, GHSA-24ww-mc5x-xc43.