CVE-2020-13947 Cross-site scripting (XSS) in Apache ActiveMQ

Medium 6.1 Published Updated

Cross-site scripting in the ActiveMQ web console allows attackers to execute scripts in victim browsers, potentially leading to session hijacking or malicious actions.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2020-13947?

CVE-2020-13947 is a medium-severity cross-site scripting vulnerability in Apache Activemq, published on 8 Feb 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

An instance of a cross-site scripting vulnerability was identified to be present in the web based administration console on the message.jsp page of Apache ActiveMQ versions 5.15.12 through 5.16.0.

Weakness: CWE-79

Which versions are affected by CVE-2020-13947?

5 open source packages ship an affected version, including org.apache.activemq:activemq-parent and activemq. It affects 3 products.

PackageAffectedFixed in
org.apache.activemq:activemq-parent MavenAll versions5.15.14
org.apache.activemq:activemq-parent MavenAll versions5.15.14
org.apache.activemq:activemq-parent MavenFrom 5.16.05.16.1
org.apache.activemq:activemq-parent MavenFrom 5.16.05.16.1
activemq BitnamiAll versions5.15.14, 5.16.1

Products include Apache Activemq, Oracle Communications Session Report Manager, Oracle Communications Session Route Manager.

How do I fix CVE-2020-13947?

Upgrade org.apache.activemq:activemq-parent to a fixed version for your release line: 5.15.14 or 5.16.1.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2020-13947 being exploited?

There is no known exploitation of CVE-2020-13947 in the wild and no public exploit code.

All Apache Activemq vulnerabilities

Sources

Also known as BIT-activemq-2020-13947, DEBIAN-CVE-2020-13947, GHSA-66gw-ch5v-74v8, UBUNTU-CVE-2020-13947.

Is CVE-2020-13947 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free