# CVE-2020-13947: Cross-site scripting (XSS) in Apache ActiveMQ

> Cross-site scripting in the ActiveMQ web console allows attackers to execute scripts in victim browsers, potentially leading to session hijacking or malicious actions.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 8 Feb 2021
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-activemq-2020-13947, DEBIAN-CVE-2020-13947, GHSA-66gw-ch5v-74v8, UBUNTU-CVE-2020-13947

## What is CVE-2020-13947?

CVE-2020-13947 is a medium-severity cross-site scripting vulnerability in Apache Activemq, published on 8 Feb 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

An instance of a cross-site scripting vulnerability was identified to be present in the web based administration console on the message.jsp page of Apache ActiveMQ versions 5.15.12 through 5.16.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-13947?

5 open source packages ship an affected version, including org.apache.activemq:activemq-parent and activemq. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.activemq:activemq-parent` | Maven | All versions | 5.15.14 |
| `org.apache.activemq:activemq-parent` | Maven | All versions | 5.15.14 |
| `org.apache.activemq:activemq-parent` | Maven | From 5.16.0 | 5.16.1 |
| `org.apache.activemq:activemq-parent` | Maven | From 5.16.0 | 5.16.1 |
| `activemq` | Bitnami | All versions | 5.15.14, 5.16.1 |

Products: Apache Activemq, Oracle Communications Session Report Manager, Oracle Communications Session Route Manager.

## How do I fix CVE-2020-13947?

Upgrade org.apache.activemq:activemq-parent to a fixed version for your release line: 5.15.14 or 5.16.1.

## Is CVE-2020-13947 being exploited?

There is no known exploitation of CVE-2020-13947 in the wild and no public exploit code.

## Other vulnerabilities in Apache Activemq

- [CVE-2023-46604](https://insights.sbomify.com/CVE-2023-46604/): Apache ActiveMQ Deserialization of Untrusted Data (critical 10.0, exploited in the wild)
- [CVE-2016-3088](https://insights.sbomify.com/CVE-2016-3088/): Apache ActiveMQ Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2026-34197](https://insights.sbomify.com/CVE-2026-34197/): Apache ActiveMQ Improper Input Validation (high 8.8, exploited in the wild)
- [CVE-2020-11998](https://insights.sbomify.com/CVE-2020-11998/): Remote code execution in Apache ActiveMQ (critical 9.8)
- [CVE-2013-7285](https://insights.sbomify.com/CVE-2013-7285/): Command Injection in Xstream (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-13947 and fix it if it is affected.

What it is: CVE-2020-13947 is a medium-severity cross-site scripting vulnerability in Apache Activemq, published on 8 Feb 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-13947 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.activemq:activemq-parent (Maven): affected all versions; fixed in 5.15.14
- org.apache.activemq:activemq-parent (Maven): affected all versions; fixed in 5.15.14
- org.apache.activemq:activemq-parent (Maven): affected from 5.16.0; fixed in 5.16.1
- org.apache.activemq:activemq-parent (Maven): affected from 5.16.0; fixed in 5.16.1
- activemq (Bitnami): affected all versions; fixed in 5.15.14, 5.16.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-13947/ (Markdown: https://insights.sbomify.com/CVE-2020-13947/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-13947
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-13947
- OSV: https://osv.dev/vulnerability/CVE-2020-13947

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-13947/
Summaries are generated and may contain mistakes; the official description above is the record.
