# CVE-2020-13948: Apache Superset OS Command Injection

> Authenticated users can inject Python code via templated fields to execute arbitrary commands and access system resources in Apache Superset.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Sep 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-superset-2020-13948, GHSA-cj7g-h7rf-h8j9, PYSEC-2020-222

## What is CVE-2020-13948?

CVE-2020-13948 is a high-severity code injection vulnerability in Apache Superset, published on 17 Sep 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

While investigating a bug report on Apache Superset, it was determined that an authenticated user could craft requests via a number of templated text fields in the product that would allow arbitrary access to Python’s `os` package in the web application process in versions < 0.37.1. It was thus possible for an authenticated user to list and access files, environment variables, and process information. Additionally it was possible to set environment variables for the current process, create and update files in folders writable by the web process, and execute arbitrary programs accessible by the web process. All other operations available to the `os` package in Python were also available, even if not explicitly enumerated in this CVE.

## Which versions are affected by CVE-2020-13948?

4 open source packages ship an affected version, including apache-superset and superset. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-superset` | PyPI | All versions | 0.37.1 |
| `apache-superset` | PyPI | All versions | 0.37.1 |
| `apache-superset` | PyPI | All versions | 0.37.1 |
| `superset` | Bitnami | All versions | 0.37.1 |

Products: Apache Superset.

## How do I fix CVE-2020-13948?

Upgrade apache-superset to 0.37.1 or later.

## Is CVE-2020-13948 being exploited?

There is no known exploitation of CVE-2020-13948 in the wild and no public exploit code.

## Other vulnerabilities in Apache Superset

- [CVE-2023-27524](https://insights.sbomify.com/CVE-2023-27524/): Apache Superset Insecure Default Initialization of Resource (high 8.9, exploited in the wild)
- [CVE-2022-27479](https://insights.sbomify.com/CVE-2022-27479/): SQL injection vulnerability in chart data API (critical 9.8)
- [CVE-2018-8021](https://insights.sbomify.com/CVE-2018-8021/): Deserialization of Untrusted Data in superset (critical 9.8)
- [CVE-2023-49657](https://insights.sbomify.com/CVE-2023-49657/): Apache Superset: Stored XSS in Dashboard Title and Chart Title (critical 9.6)
- [CVE-2022-43719](https://insights.sbomify.com/CVE-2022-43719/): Apache Superset: Cross Site Request Forgery (CSRF) on accept, request access API (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-13948 and fix it if it is affected.

What it is: CVE-2020-13948 is a high-severity code injection vulnerability in Apache Superset, published on 17 Sep 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-13948 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-superset (PyPI): affected all versions; fixed in 0.37.1
- apache-superset (PyPI): affected all versions; fixed in 0.37.1
- apache-superset (PyPI): affected all versions; fixed in 0.37.1
- superset (Bitnami): affected all versions; fixed in 0.37.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-13948/ (Markdown: https://insights.sbomify.com/CVE-2020-13948/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-13948
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-13948
- OSV: https://osv.dev/vulnerability/CVE-2020-13948

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-13948/
Summaries are generated and may contain mistakes; the official description above is the record.
