# CVE-2020-13950: mod_proxy_http NULL pointer dereference

> Attackers can crash Apache HTTP Server by sending crafted requests with conflicting headers, causing a denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jun 2021
- **Updated:** 4 Aug 2024
- **Also known as:** ALPINE-CVE-2020-13950, AZL-6474, BIT-apache-2020-13950, CLEANSTART-2026-KT91017, DEBIAN-CVE-2020-13950, GHSA-pqc6-p826-c5qw, RHSA-2022:5163, RLSA-2022:5163, UBUNTU-CVE-2020-13950

## What is CVE-2020-13950?

CVE-2020-13950 is a high-severity vulnerability in Apache Http Server, published on 10 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache HTTP Server versions 2.4.41 to 2.4.46 mod_proxy_http can be made to crash (NULL pointer dereference) with specially crafted requests using both Content-Length and Transfer-Encoding headers, leading to a Denial of Service

Weakness: CWE-476 (NULL Pointer Dereference)

## Which versions are affected by CVE-2020-13950?

1 open source package ship an affected version, including apache. It affects 6 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache` | Bitnami | From 2.4.41 | 2.4.47 |
| `httpd` | Red Hat:enterprise_linux:8::appstream | All versions | 0:2.4.37-47.module+el8.6.0+15654+427eba2e.2 |
| `httpd-debuginfo` | Red Hat:enterprise_linux:8::appstream | All versions | 0:2.4.37-47.module+el8.6.0+15654+427eba2e.2 |
| `httpd-debugsource` | Red Hat:enterprise_linux:8::appstream | All versions | 0:2.4.37-47.module+el8.6.0+15654+427eba2e.2 |
| `httpd-devel` | Red Hat:enterprise_linux:8::appstream | All versions | 0:2.4.37-47.module+el8.6.0+15654+427eba2e.2 |
| `httpd-filesystem` | Red Hat:enterprise_linux:8::appstream | All versions | 0:2.4.37-47.module+el8.6.0+15654+427eba2e.2 |
| `httpd-manual` | Red Hat:enterprise_linux:8::appstream | All versions | 0:2.4.37-47.module+el8.6.0+15654+427eba2e.2 |
| `httpd-tools` | Red Hat:enterprise_linux:8::appstream | All versions | 0:2.4.37-47.module+el8.6.0+15654+427eba2e.2 |
| `httpd-tools-debuginfo` | Red Hat:enterprise_linux:8::appstream | All versions | 0:2.4.37-47.module+el8.6.0+15654+427eba2e.2 |
| `mod_http2` | Red Hat:enterprise_linux:8::appstream | All versions | 0:1.15.7-5.module+el8.6.0+13996+01710940 |
| `mod_http2-debuginfo` | Red Hat:enterprise_linux:8::appstream | All versions | 0:1.15.7-5.module+el8.6.0+13996+01710940 |
| `mod_http2-debugsource` | Red Hat:enterprise_linux:8::appstream | All versions | 0:1.15.7-5.module+el8.6.0+13996+01710940 |
| `mod_ldap` | Red Hat:enterprise_linux:8::appstream | All versions | 0:2.4.37-47.module+el8.6.0+15654+427eba2e.2 |
| `mod_ldap-debuginfo` | Red Hat:enterprise_linux:8::appstream | All versions | 0:2.4.37-47.module+el8.6.0+15654+427eba2e.2 |
| `mod_md` | Red Hat:enterprise_linux:8::appstream | All versions | 1:2.0.8-8.module+el8.3.0+6814+67d1e611 |
| `mod_md-debuginfo` | Red Hat:enterprise_linux:8::appstream | All versions | 1:2.0.8-8.module+el8.3.0+6814+67d1e611 |
| `mod_md-debugsource` | Red Hat:enterprise_linux:8::appstream | All versions | 1:2.0.8-8.module+el8.3.0+6814+67d1e611 |
| `mod_proxy_html` | Red Hat:enterprise_linux:8::appstream | All versions | 1:2.4.37-47.module+el8.6.0+15654+427eba2e.2 |
| `mod_proxy_html-debuginfo` | Red Hat:enterprise_linux:8::appstream | All versions | 1:2.4.37-47.module+el8.6.0+15654+427eba2e.2 |
| `mod_session` | Red Hat:enterprise_linux:8::appstream | All versions | 0:2.4.37-47.module+el8.6.0+15654+427eba2e.2 |
| `mod_session-debuginfo` | Red Hat:enterprise_linux:8::appstream | All versions | 0:2.4.37-47.module+el8.6.0+15654+427eba2e.2 |
| `mod_ssl` | Red Hat:enterprise_linux:8::appstream | All versions | 1:2.4.37-47.module+el8.6.0+15654+427eba2e.2 |
| `mod_ssl-debuginfo` | Red Hat:enterprise_linux:8::appstream | All versions | 1:2.4.37-47.module+el8.6.0+15654+427eba2e.2 |
| `httpd` | Rocky Linux:8 | All versions | 0:2.4.37-47.module+el8.6.0+823+f143cee1.1 |
| `mod_http2` | Rocky Linux:8 | All versions | 0:1.15.7-5.module+el8.6.0+823+f143cee1 |
| `mod_md` | Rocky Linux:8 | All versions | 1:2.0.8-8.module+el8.4.0+553+7a69454b |
| `mod_md` | Rocky Linux:8 | All versions | 1:2.0.8-8.module+el8.5.0+695+1fa8055e |

Products: Apache Http Server, Debian Debian Linux, Fedoraproject Fedora, Oracle Enterprise Manager Ops Center, Oracle Instantis Enterprisetrack, Oracle Zfs Storage Appliance Kit.

## How do I fix CVE-2020-13950?

Upgrade apache to 2.4.47 or later.

## Is CVE-2020-13950 being exploited?

There is no known exploitation of CVE-2020-13950 in the wild and no public exploit code.

## Other vulnerabilities in Apache Http Server

- [CVE-2021-42013](https://insights.sbomify.com/CVE-2021-42013/): Apache HTTP Server Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2024-38475](https://insights.sbomify.com/CVE-2024-38475/): Apache HTTP Server Improper Escaping of Output (critical 9.1, exploited in the wild)
- [CVE-2021-40438](https://insights.sbomify.com/CVE-2021-40438/): Apache HTTP Server-Side Request Forgery (SSRF) (critical 9.0, exploited in the wild)
- [CVE-2019-0211](https://insights.sbomify.com/CVE-2019-0211/): Apache HTTP Server Privilege Escalation (high 7.8, exploited in the wild)
- [CVE-2021-41773](https://insights.sbomify.com/CVE-2021-41773/): Apache HTTP Server Path Traversal (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-13950 and fix it if it is affected.

What it is: CVE-2020-13950 is a high-severity vulnerability in Apache Http Server, published on 10 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-13950 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache (Bitnami): affected from 2.4.41; fixed in 2.4.47

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-13950/ (Markdown: https://insights.sbomify.com/CVE-2020-13950/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-13950
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-13950
- OSV: https://osv.dev/vulnerability/CVE-2020-13950

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-13950/
Summaries are generated and may contain mistakes; the official description above is the record.
