# CVE-2020-13952: Plaintext password leak in Apache Superset

> Authenticated users can access sensitive metadata, hashed passwords, and connection credentials, and bypass internal security controls via templated fields.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Sep 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-superset-2020-13952, GHSA-77pw-c3j2-5fc8, PYSEC-2020-223

## What is CVE-2020-13952?

CVE-2020-13952 is a high-severity vulnerability in Apache Superset, published on 30 Sep 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In the course of work on the open source project it was discovered that authenticated users running queries against Hive and Presto database engines could access information via a number of templated fields including the contents of query description metadata database, the hashed version of the authenticated users’ password, and access to connection information including the plaintext password for the current connection. It would also be possible to run arbitrary methods on the database connection object for the Presto or Hive connection, allowing the user to bypass security controls internal to Superset. This vulnerability is present in every Apache Superset version < 0.37.2.

## Which versions are affected by CVE-2020-13952?

4 open source packages ship an affected version, including apache-superset and superset. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-superset` | PyPI | All versions | 0.37.2 |
| `apache-superset` | PyPI | All versions | 0.37.2 |
| `apache-superset` | PyPI | All versions | 0.37.2 |
| `superset` | Bitnami | All versions | 0.37.2 |

Products: Apache Superset.

## How do I fix CVE-2020-13952?

Upgrade apache-superset to 0.37.2 or later.

## Is CVE-2020-13952 being exploited?

There is no known exploitation of CVE-2020-13952 in the wild and no public exploit code.

## Other vulnerabilities in Apache Superset

- [CVE-2023-27524](https://insights.sbomify.com/CVE-2023-27524/): Apache Superset Insecure Default Initialization of Resource (high 8.9, exploited in the wild)
- [CVE-2022-27479](https://insights.sbomify.com/CVE-2022-27479/): SQL injection vulnerability in chart data API (critical 9.8)
- [CVE-2018-8021](https://insights.sbomify.com/CVE-2018-8021/): Deserialization of Untrusted Data in superset (critical 9.8)
- [CVE-2023-49657](https://insights.sbomify.com/CVE-2023-49657/): Apache Superset: Stored XSS in Dashboard Title and Chart Title (critical 9.6)
- [CVE-2022-43719](https://insights.sbomify.com/CVE-2022-43719/): Apache Superset: Cross Site Request Forgery (CSRF) on accept, request access API (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-13952 and fix it if it is affected.

What it is: CVE-2020-13952 is a high-severity vulnerability in Apache Superset, published on 30 Sep 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-13952 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-superset (PyPI): affected all versions; fixed in 0.37.2
- apache-superset (PyPI): affected all versions; fixed in 0.37.2
- apache-superset (PyPI): affected all versions; fixed in 0.37.2
- superset (Bitnami): affected all versions; fixed in 0.37.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-13952/ (Markdown: https://insights.sbomify.com/CVE-2020-13952/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-13952
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-13952
- OSV: https://osv.dev/vulnerability/CVE-2020-13952

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-13952/
Summaries are generated and may contain mistakes; the official description above is the record.
