# CVE-2020-13957: Incorrect Authorization in Apache Solr

> Attackers can bypass security checks to upload dangerous configurations via the API, potentially leading to remote code execution in Apache Solr.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Oct 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-solr-2020-13957, GHSA-3c7p-vv5r-cmr5

## What is CVE-2020-13957?

CVE-2020-13957 is a critical missing authorization vulnerability in Apache Solr, published on 13 Oct 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache Solr versions 6.6.0 to 6.6.6, 7.0.0 to 7.7.3 and 8.0.0 to 8.6.2 prevents some features considered dangerous (which could be used for remote code execution) to be configured in a ConfigSet that's uploaded via API without authentication/authorization. The checks in place to prevent such features can be circumvented by using a combination of UPLOAD/CREATE actions.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2020-13957?

7 open source packages ship an affected version, including org.apache.solr:solr-core, solr and org.apache.solr:solr-parent. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.solr:solr-core` | Maven | From 6.6.0 | 8.6.3 |
| `org.apache.solr:solr-core` | Maven | From 6.6.0 | 8.6.3 |
| `solr` | Bitnami | From 6.6.0 | 6.6.7, 7.7.4, 8.6.3 |
| `org.apache.solr:solr-parent` | Maven | From 6.6.0 | 8.6.3 |
| `org.apache.solr:solr-parent` | Maven | From 6.6.0 | 8.6.3 |
| `org.apache.solr:solr-solrj` | Maven | From 6.6.0 | 8.6.3 |
| `org.apache.solr:solr-solrj` | Maven | From 6.6.0 | 8.6.3 |

Products: Apache Solr.

## How do I fix CVE-2020-13957?

Upgrade org.apache.solr:solr-core to 8.6.3 or later.

## Is CVE-2020-13957 being exploited?

There is no known exploitation of CVE-2020-13957 in the wild and no public exploit code.

Public exploit code:

- Apache Solr RCE CVE-2020-13957 (github_poc): https://github.com/s-index/CVE-2020-13957

## Other vulnerabilities in Apache Solr

- [CVE-2019-17558](https://insights.sbomify.com/CVE-2019-17558/): Apache Solr VelocityResponseWriter Plug-In Remote Code Execution (high 7.5, exploited in the wild)
- [CVE-2019-0193](https://insights.sbomify.com/CVE-2019-0193/): Apache Solr DataImportHandler Code Injection (high 7.2, exploited in the wild)
- [CVE-2024-45216](https://insights.sbomify.com/CVE-2024-45216/): Apache Solr: Authentication bypass possible using a fake URL Path ending (critical 9.8)
- [CVE-2021-44548](https://insights.sbomify.com/CVE-2021-44548/): Apache Solr information disclosure vulnerability through DataImportHandler (critical 9.8)
- [CVE-2021-27905](https://insights.sbomify.com/CVE-2021-27905/): SSRF vulnerability with the Replication handler (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-13957 and fix it if it is affected.

What it is: CVE-2020-13957 is a critical missing authorization vulnerability in Apache Solr, published on 13 Oct 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-13957 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.solr:solr-core (Maven): affected from 6.6.0; fixed in 8.6.3
- org.apache.solr:solr-core (Maven): affected from 6.6.0; fixed in 8.6.3
- solr (Bitnami): affected from 6.6.0; fixed in 6.6.7, 7.7.4, 8.6.3
- org.apache.solr:solr-parent (Maven): affected from 6.6.0; fixed in 8.6.3
- org.apache.solr:solr-parent (Maven): affected from 6.6.0; fixed in 8.6.3
- org.apache.solr:solr-solrj (Maven): affected from 6.6.0; fixed in 8.6.3
- org.apache.solr:solr-solrj (Maven): affected from 6.6.0; fixed in 8.6.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-13957/ (Markdown: https://insights.sbomify.com/CVE-2020-13957/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-13957
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-13957
- OSV: https://osv.dev/vulnerability/CVE-2020-13957

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-13957/
Summaries are generated and may contain mistakes; the official description above is the record.
