# CVE-2020-13961: Improper Input Validation in strapi

> Authenticated attackers can inject malicious code into email templates via unsanitized global variables, allowing modification of password reset and confirmation emails.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Jun 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-65wv-528r-m892

## What is CVE-2020-13961?

CVE-2020-13961 is a medium-severity code injection vulnerability in n/a, published on 19 Jun 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Strapi before 3.0.2 could allow a remote authenticated attacker to bypass security restrictions because templates are stored in a global variable without any sanitation. By sending a specially crafted request, an attacker could exploit this vulnerability to update the email template for both password reset and account confirmation emails.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2020-13961?

2 open source packages ship an affected version, including strapi. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `strapi` | npm | All versions | 3.0.2 |
| `strapi` | npm | All versions | 3.0.2 |

Products: Strapi Strapi.

## How do I fix CVE-2020-13961?

Upgrade strapi to 3.0.2 or later.

## Is CVE-2020-13961 being exploited?

There is no known exploitation of CVE-2020-13961 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-22894](https://insights.sbomify.com/CVE-2023-22894/): Strapi Cleartext Storage of Sensitive Information (high 7.2, exploited in the wild)
- [CVE-2023-22621](https://insights.sbomify.com/CVE-2023-22621/): Strapi plugins vulnerable to Server-Side Template Injection and Remote Code Execution in the Users-Permissions Plugin (critical 10.0)
- [CVE-2022-27263](https://insights.sbomify.com/CVE-2022-27263/): Unrestricted Upload of File with Dangerous Type in Strapi (critical 9.8)
- [CVE-2020-27664](https://insights.sbomify.com/CVE-2020-27664/): Authorization bypass in Strapi (critical 9.8)
- [CVE-2019-18818](https://insights.sbomify.com/CVE-2019-18818/): Strapi allows unauthenticated attacker to reset admin password without valid reset token (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-13961 and fix it if it is affected.

What it is: CVE-2020-13961 is a medium-severity code injection vulnerability in n/a, published on 19 Jun 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-13961 in the wild and no public exploit code.

Affected packages and fixed versions:
- strapi (npm): affected all versions; fixed in 3.0.2
- strapi (npm): affected all versions; fixed in 3.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-13961/ (Markdown: https://insights.sbomify.com/CVE-2020-13961/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-13961
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-13961
- OSV: https://osv.dev/vulnerability/CVE-2020-13961

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-13961/
Summaries are generated and may contain mistakes; the official description above is the record.
