{"answers":{"affected":"It affects 4 products.","exploited":"There is no known exploitation of CVE-2020-13962 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2020-13962 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 8 Jun 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-13962 and fix it if it is affected.\n\nWhat it is: CVE-2020-13962 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 8 Jun 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-13962 in the wild and no public exploit code.\n\nAffected product: Fedoraproject Fedora. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-13962/ (Markdown: https://insights.sbomify.com/CVE-2020-13962/index.md)","id":"CVE-2020-13962","markdown":"https://insights.sbomify.com/CVE-2020-13962/index.md","name":"CVE-2020-13962","record":{"aliases":["AZL-6835","DEBIAN-CVE-2020-13962","GHSA-c4xh-w73g-qgf6","MGASA-2021-0200","SUSE-SU-2020:2357-1","UBUNTU-CVE-2020-13962","openSUSE-SU-2020:1319-1","openSUSE-SU-2024:11742-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Qt SSL library","requires_auth":"none","summary":"Mishandling of OpenSSL error queue in Qt allows attackers to cause denial of service by disconnecting unrelated TLS sessions.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"mumble","vendor":"mumble"},{"product":"leap","vendor":"opensuse"},{"product":"qt","vendor":"qt"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[],"description":"Qt 5.12.2 through 5.14.2, as used in unofficial builds of Mumble 1.3.0 and other products, mishandles OpenSSL's error queue, which can cause a denial of service to QSslSocket users. Because errors leak in unrelated TLS sessions, an unrelated session may be disconnected when any handshake fails. (Mumble 1.3.1 is not affected, regardless of the Qt version.)","ecosystems":["SUSE:Linux Enterprise Module for Basesystem 15 SP2","SUSE:Linux Enterprise Module for Desktop Applications 15 SP2","openSUSE:Leap 15.2","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in n/a","id":"CVE-2020-13962","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"fedoraproject:fedora","products":["fedoraproject:fedora","opensuse:leap","qt:qt"],"type":"denial_of_service","year":"2020"},"n_packages":4,"n_references":8,"next":{"headline":"Hardcoded credentials in n/a","id":"CVE-2020-13963"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Module for Basesystem 15 SP2","fixed":["5.12.7-4.3.1"],"introduced":["0"],"last_affected":[],"package":"libqt5-qtbase","purl":"pkg:rpm/suse/libqt5-qtbase\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Basesystem%2015%20SP2","source":"SUSE-SU-2020:2357-1"},{"ecosystem":"SUSE:Linux Enterprise Module for Desktop Applications 15 SP2","fixed":["5.12.7-4.3.1"],"introduced":["0"],"last_affected":[],"package":"libqt5-qtbase","purl":"pkg:rpm/suse/libqt5-qtbase\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Desktop%20Applications%2015%20SP2","source":"SUSE-SU-2020:2357-1"},{"ecosystem":"openSUSE:Leap 15.2","fixed":["5.12.7-lp152.3.3.1"],"introduced":["0"],"last_affected":[],"package":"libqt5-qtbase","purl":"pkg:rpm/opensuse/libqt5-qtbase\u0026distro=openSUSE%20Leap%2015.2","source":"openSUSE-SU-2020:1319-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["5.15.2+kde268-2.1"],"introduced":["0"],"last_affected":[],"package":"libqt5-qtbase","purl":"pkg:rpm/opensuse/libqt5-qtbase\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:11742-1"}],"prev":{"headline":"Improper Input Validation in strapi","id":"CVE-2020-13961"},"products":["n/a"],"published":"2020-06-08","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Mishandling of OpenSSL error queue in Qt allows attackers to cause denial of service by disconnecting unrelated TLS sessions.","url":"https://insights.sbomify.com/CVE-2020-13962/"}