CVE-2020-13964 Cross-site scripting in n/a
Attackers can execute arbitrary scripts in victim browsers via the username template object in Roundcube Webmail, potentially leading to session hijacking.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2020-13964?
CVE-2020-13964 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 9 Jun 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
An issue was discovered in Roundcube Webmail before 1.3.12 and 1.4.x before 1.4.5. include/rcmail_output_html.php allows XSS via the username template object.
Weakness: CWE-79
Which versions are affected by CVE-2020-13964?
1 open source package ship an affected version, including roundcube. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
roundcube Bitnami | All versions | 1.3.12, 1.4.5 |
Products include Debian Debian Linux, Fedoraproject Fedora, Roundcube Webmail.
How do I fix CVE-2020-13964?
Upgrade roundcube to a fixed version for your release line: 1.3.12 or 1.4.5.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2020-13964 being exploited?
There is no known exploitation of CVE-2020-13964 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as BIT-roundcube-2020-13964, DEBIAN-CVE-2020-13964, GHSA-x5vh-j6xf-cfg4, UBUNTU-CVE-2020-13964.