CVE-2020-13965 Roundcube Webmail Cross-Site Scripting (XSS)
Attackers can execute arbitrary scripts in victim browsers via malicious XML attachments in Roundcube Webmail previews.
- Exploited in the wild
- Since 26 Jun 2024
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2020-13965?
CVE-2020-13965 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 9 Jun 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
An issue was discovered in Roundcube Webmail before 1.3.12 and 1.4.x before 1.4.5. There is XSS via a malicious XML attachment because text/xml is among the allowed types for a preview.
Which versions are affected by CVE-2020-13965?
1 open source package ship an affected version, including roundcube. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
roundcube Bitnami | All versions | 1.3.12, 1.4.5 |
Products include Debian Debian Linux, Fedoraproject Fedora, Roundcube Webmail.
How do I fix CVE-2020-13965?
Upgrade roundcube to a fixed version for your release line: 1.3.12 or 1.4.5. US federal agencies must fix it by 17 Jul 2024.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2020-13965 being exploited?
Yes. Attackers have exploited CVE-2020-13965 in the wild since at least 26 Jun 2024.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as BIT-roundcube-2020-13965, DEBIAN-CVE-2020-13965, GHSA-44qp-5pm8-6j8p, UBUNTU-CVE-2020-13965.