# CVE-2020-13965: Roundcube Webmail Cross-Site Scripting (XSS)

> Attackers can execute arbitrary scripts in victim browsers via malicious XML attachments in Roundcube Webmail previews.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Yes, since 26 Jun 2024 (CISA KEV)
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Jun 2020
- **Updated:** 21 Oct 2025
- **Also known as:** BIT-roundcube-2020-13965, DEBIAN-CVE-2020-13965, GHSA-44qp-5pm8-6j8p, UBUNTU-CVE-2020-13965

## What is CVE-2020-13965?

CVE-2020-13965 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 9 Jun 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

An issue was discovered in Roundcube Webmail before 1.3.12 and 1.4.x before 1.4.5. There is XSS via a malicious XML attachment because text/xml is among the allowed types for a preview.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-80 (Improper Neutralization of Script-Related HTML Tags in a Web Page)

## Which versions are affected by CVE-2020-13965?

1 open source package ship an affected version, including roundcube. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `roundcube` | Bitnami | All versions | 1.3.12, 1.4.5 |

Products: Debian Debian Linux, Fedoraproject Fedora, Roundcube Webmail.

## How do I fix CVE-2020-13965?

Upgrade roundcube to a fixed version for your release line: 1.3.12 or 1.4.5. US federal agencies must fix it by 17 Jul 2024.

## Is CVE-2020-13965 being exploited?

Yes. Attackers have exploited CVE-2020-13965 in the wild since at least 26 Jun 2024.

Public exploit code:

- CVE-2020-13965: Cross-Site Scripting via Malicious XML Attachment in Roundcube Webmail (github_poc): https://github.com/mbadanoiu/CVE-2020-13965

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-13965 and fix it if it is affected.

What it is: CVE-2020-13965 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 9 Jun 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: Yes. Attackers have exploited CVE-2020-13965 in the wild since at least 26 Jun 2024.

Affected packages and fixed versions:
- roundcube (Bitnami): affected all versions; fixed in 1.3.12, 1.4.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-13965/ (Markdown: https://insights.sbomify.com/CVE-2020-13965/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-13965
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-13965
- OSV: https://osv.dev/vulnerability/CVE-2020-13965

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-13965/
Summaries are generated and may contain mistakes; the official description above is the record.
