# CVE-2020-14001: Unintended read access in kramdown gem

> The kramdown gem allows remote attackers to execute arbitrary Ruby code or read sensitive files via the template option.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jul 2020
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2020-14001, DLA-2316-1, DSA-4743-1, GHSA-mqm2-cgpr-p4m6, OESA-2021-1280, SUSE-SU-2022:3259-1, UBUNTU-CVE-2020-14001, USN-4562-1

## What is CVE-2020-14001?

CVE-2020-14001 is a critical code injection vulnerability in Canonical Ubuntu Linux, published on 17 Jul 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The kramdown gem before 2.3.0 for Ruby processes the template option inside Kramdown documents by default, which allows unintended read access (such as template="/etc/passwd") or unintended embedded Ruby code execution (such as a string that begins with template="string://<%= `). NOTE: kramdown is used in Jekyll, GitLab Pages, GitHub Pages, and Thredded Forum.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2020-14001?

2 open source packages ship an affected version, including kramdown. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `kramdown` | RubyGems | All versions | 2.3.0 |
| `kramdown` | RubyGems | All versions | 2.3.0 |
| `rubygem-kramdown` | SUSE:Linux Enterprise High Availability Extension 15 | All versions | 1.15.0-150000.3.3.1 |
| `rubygem-kramdown` | SUSE:Linux Enterprise High Availability Extension 15 SP1 | All versions | 1.15.0-150000.3.3.1 |
| `rubygem-kramdown` | SUSE:Linux Enterprise High Availability Extension 15 SP2 | All versions | 1.15.0-150000.3.3.1 |
| `rubygem-kramdown` | SUSE:Linux Enterprise High Availability Extension 15 SP3 | All versions | 1.15.0-150000.3.3.1 |
| `rubygem-kramdown` | SUSE:Linux Enterprise High Availability Extension 15 SP4 | All versions | 1.15.0-150000.3.3.1 |
| `rubygem-kramdown` | openSUSE:Leap 15.3 | All versions | 1.15.0-150000.3.3.1 |
| `rubygem-kramdown` | openSUSE:Leap 15.4 | All versions | 1.15.0-150000.3.3.1 |

Products: Canonical Ubuntu Linux, Debian Debian Linux, Fedoraproject Fedora, Kramdown Project Kramdown.

## How do I fix CVE-2020-14001?

Upgrade kramdown to 2.3.0 or later.

## Is CVE-2020-14001 being exploited?

There is no known exploitation of CVE-2020-14001 in the wild and no public exploit code.

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11651](https://insights.sbomify.com/CVE-2020-11651/): SaltStack Salt Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-7247](https://insights.sbomify.com/CVE-2020-7247/): OpenSMTPD Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2019-16928](https://insights.sbomify.com/CVE-2019-16928/): Exim Out-of-bounds Write (critical 9.8, exploited in the wild)
- [CVE-2018-6789](https://insights.sbomify.com/CVE-2018-6789/): Exim Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2015-2590](https://insights.sbomify.com/CVE-2015-2590/): Oracle Java SE and Java SE Embedded Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-14001 and fix it if it is affected.

What it is: CVE-2020-14001 is a critical code injection vulnerability in Canonical Ubuntu Linux, published on 17 Jul 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-14001 in the wild and no public exploit code.

Affected packages and fixed versions:
- kramdown (RubyGems): affected all versions; fixed in 2.3.0
- kramdown (RubyGems): affected all versions; fixed in 2.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-14001/ (Markdown: https://insights.sbomify.com/CVE-2020-14001/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-14001
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-14001
- OSV: https://osv.dev/vulnerability/CVE-2020-14001

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-14001/
Summaries are generated and may contain mistakes; the official description above is the record.
