# CVE-2020-14019: rtslib-fb weak permissions for /etc/target/saveconfig.json file

> Weak file permissions on saveconfig.json allow local attackers to read sensitive iSCSI target configuration data.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Jun 2020
- **Updated:** 4 Aug 2024
- **Also known as:** AZL-44778, DEBIAN-CVE-2020-14019, GHSA-cpcw-p965-wpqx, MGASA-2020-0336, PYSEC-2020-250, RHEA-2020:4505, RHSA-2020:5435, SUSE-SU-2020:2109-1, UBUNTU-CVE-2020-14019, openSUSE-SU-2020:1156-1, openSUSE-SU-2024:11270-1

## What is CVE-2020-14019?

CVE-2020-14019 is a high-severity vulnerability in n/a, published on 19 Jun 2020. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Open-iSCSI rtslib-fb through 2.1.72 has weak permissions for /etc/target/saveconfig.json because shutil.copyfile (instead of shutil.copy) is used, and thus permissions are not preserved.

Weakness: CWE-276 (Incorrect Default Permissions)

## Which versions are affected by CVE-2020-14019?

3 open source packages ship an affected version, including rtslib-fb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rtslib-fb` | PyPI | All versions | 2.1.73 |
| `rtslib-fb` | PyPI | All versions | 2.1.73 |
| `rtslib-fb` | PyPI | All versions | 2.1.73 |
| `python-rtslib` | Red Hat:enterprise_linux:7::client | All versions | 0:2.1.74-1.el7_9 |
| `python-rtslib-doc` | Red Hat:enterprise_linux:7::client | All versions | 0:2.1.74-1.el7_9 |
| `python-rtslib-doc` | Red Hat:enterprise_linux:7::computenode | All versions | 0:2.1.74-1.el7_9 |
| `python-rtslib` | Red Hat:enterprise_linux:7::server | All versions | 0:2.1.74-1.el7_9 |
| `python-rtslib-doc` | Red Hat:enterprise_linux:7::server | All versions | 0:2.1.74-1.el7_9 |
| `python-rtslib` | Red Hat:enterprise_linux:7::workstation | All versions | 0:2.1.74-1.el7_9 |
| `python-rtslib-doc` | Red Hat:enterprise_linux:7::workstation | All versions | 0:2.1.74-1.el7_9 |
| `python-rtslib` | Red Hat:enterprise_linux:8::baseos | All versions | 0:2.1.73-2.el8 |
| `python3-rtslib` | Red Hat:enterprise_linux:8::baseos | All versions | 0:2.1.73-2.el8 |
| `target-restore` | Red Hat:enterprise_linux:8::baseos | All versions | 0:2.1.73-2.el8 |
| `python-rtslib-fb` | SUSE:Linux Enterprise Module for Basesystem 15 SP2 | All versions | 2.1.73-3.3.1 |
| `python-rtslib-fb` | SUSE:Linux Enterprise Module for Python 2 15 SP2 | All versions | 2.1.73-3.3.1 |
| `python-rtslib-fb` | openSUSE:Leap 15.2 | All versions | 2.1.73-lp152.2.3.1 |

Products: Rtslib-Fb Project Rtslib-Fb.

## How do I fix CVE-2020-14019?

Upgrade rtslib-fb to 2.1.73 or later.

## Is CVE-2020-14019 being exploited?

There is no known exploitation of CVE-2020-14019 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-14019 and fix it if it is affected.

What it is: CVE-2020-14019 is a high-severity vulnerability in n/a, published on 19 Jun 2020. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-14019 in the wild and no public exploit code.

Affected packages and fixed versions:
- rtslib-fb (PyPI): affected all versions; fixed in 2.1.73
- rtslib-fb (PyPI): affected all versions; fixed in 2.1.73
- rtslib-fb (PyPI): affected all versions; fixed in 2.1.73

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-14019/ (Markdown: https://insights.sbomify.com/CVE-2020-14019/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-14019
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-14019
- OSV: https://osv.dev/vulnerability/CVE-2020-14019

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-14019/
Summaries are generated and may contain mistakes; the official description above is the record.
